F3D is associated with EVERY file type. How to remove?

I installed this:

The problem is that somehow, it is associated with EVERY file type. When right-clicking a hidden file on SMB share, F3D is set as the default app. “F3D” has been added for all file type entries. Like hundreds of them. So, it’s not possible to remove F3D. See below. It’s just two examples, but F3D is in EVERY file type in Settings → Default Applications → File Associations.

image

image

How to remove F3D from all the unrelated file extensions? It’s a 3D data viewer, so it should only be associated with 3D files.

It depends how the associations have been set. If they are set in ~/.config/mimeapps.list you can just delete them. Or, if the associations are provided by a mimetype file you can use xdg-mime to remove them.

A more extreme intervention would be to make a custom desktop file for the application (cp /usr/share/applications/some_application.desktop ~/.local/share/applications/) and remove the unwanted associations from desktop file itself.

If you want a nice easy GUI tool I sometimes use this one: https://aur.archlinux.org/packages/selectdefaultapplication-fork-git It’s a lot faster and easier than doing it manually. The package hasn’t been updated in over a year, but then again it’s already feature complete so I don’t know what there would be to update unless the app developed a bug.

1 Like

I’m pretty sure plasma has a native way to mange these types in system settings. You would need to look for file associations. The problem with this method is that you will be doing it manually for each type

You are both right, somewhat. Yes, KDE has a “Default Applications” feature, but I’ve installed F3D before, it is an annoying app that associates itself with everything.

@yourgod
The best route would be to remove all its associations from a config file by using “Find and Replace”, then re-add the ones you want it to be associated with as needed by using the right-click menu.

Is it intentional or a bug? Why does a 3D file viewer associate itself to LibreOffice files?

This is most definitely a bug, even if it’s for whatever reason intentional.

Like the first comment says, editing the file associations config file is an option. For me, it’s the only option, because doing it one-by-one is a waste of time.

Just open the config file in a text editor, use find and replace for “f3d;”, but don’t type anything into the replace section. This is essentially the same as deleting all entries for f3d all at once.

Notice the ; after f3d by the way.

PS: Don’t just follow the suggestions you get, actually look at what it’s doing to make sure there are no mistakes.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.