Extremely slow Laptop since Kernel Update

Hello, I have switch from windows to Manjaro and then I was like Let’s try EndeavourOS so please consider me as a fresh blood that half the time does not know what he is doing…
Here is my configuration:

Operating System: EndeavourOS
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.14.2-arch1-2 (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 7 4700U with Radeon Graphics
Memory: 14.9 GiB of RAM
Graphics Processor: AMD RENOIR

Everything was working amazingly after a fresh install of Endeavour and yesterday while updating my system with yay -Syu I was excited to see a new Kernel update!
But unfortunately since the update my laptop is lagging like I never seen anything like that before since windows 95! I can’t even write this post without having massive delay or lag…
Did I miss something that I should have done after going from kernel 5.13 to 5.14?
Thanks in advance for all the reply! Have a nice day!

go install LTS kernel to see if it is kernel issue…

sudo pacman -S linux-lts linux-lts-headers

edit and if you can give logs so we can see if something other than the kernel is causing issues…

lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | eos-sendlog
3 Likes

First things first, welcome to the EndeavourOS community forums, it’s a great place and personally one of the reasons why I like to use EndeavourOS so much so help, to read, and to learn; these forums are a great place for all of that. Now with that intro out of the way…

There’s no need to run yay -Syu you can just run yay it does the same exact thing, checks Arch/EndeavourOS repos, then checks the AUR for any updates. I’d also recommend using the LTS kernel over the latest kernel since it is more than likely to have bugs/regressions being on the latest kernel. You may install the LTS kernel as @joekamprad has mentions above, or if you like GUI’s you can use EndeavourOS’s own app akm to install the LTS kernel as well if you prefer. If you do it this way, just make sure you select both core/linux-lts and core/linux-lts-headers for 5.10 and give your system a reboot and hopefully (fingers crossed) you don’t have any more issues! Let us know how it all goes and good luck.

2 Likes

Hello @joekamprad @Scotty_Trees ! Thanks a lot I really appreciate both your help! So I just used Akm and install both LTS and LTS header and this seem to have fixed my issue of a very very slow experience…
Now to keep it clean should I remove the 5.14 with yay -Rs 5.14.2arch1-2 ?

Thanks again for the Help!

Welcome @hsdredgun
My Ryzen 4700U HP laptop is running fine on Xfce. I also have KDE running on a Ryzen 3800x with AMD RX 590 graphics. Also no issues.

1 Like

keep the main kernel, you can try again to boot with it on one of the next updates, to see if the issue is gone…

Great, glad to hear it worked out okay so far! Also worth knowing that when you have both kernels installed, your system will automatically boot into the LTS kernel every time you reboot. If you want to boot back into the latest kernel (currently 5.14), you’ll have to always manually select it before boot. I edited my grub to automatically default to which ever kernel I last used previously. I can tell you how to do that if you like, otherwise I would just recommend sticking with the LTS kernel and things should be good to go for you :slight_smile:

I’m using at the moment the 5.14 and this worked perfectly I just needed to install the LTS to make the 5.14 work! I’m learning every day something with Linux… Thanks again for help @joekamprad and @Scotty_Trees.
@Scotty_Trees Yes I would love to know how to do this would be a much easier process than selecting each time the latest Kernel if you don’t mind… Plus I love learning stuff!

Unless I’m mistaken or perhaps that was a typo? You’re running 5.14 or 5.10 (LTS) right now? Based on your comment above, I just want to clear something up if it wasn’t a typo. Installing an LTS kernel is independent of any other kernel you have on your system. So if 5.14 wasn’t working for you, and you installed 5.10, but booted into 5.14 to be working, that LTS kernel shouldn’t have any effect whatsoever on the 5.14 kernel. Which if that is your case, then it’s possible you may have another issue in the mix. Unless of course you meant you’re running 5.10 at the moment.

I’m running the 5.14 at the moment and surprisingly installing the LTS made it work I have 0 lags anymore it’s back to the perfect normal… Very strange because I am agreed with you it should not have change anything 5.10 and 5.14 are two different things right?
Operating System: EndeavourOS
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.14.2-arch1-2 (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 7 4700U with Radeon Graphics
Memory: 14.9 GiB of RAM
Graphics Processor: AMD RENOIR

Well, sometimes when you update, certain system files that just got updated definitely require a reboot after in order to ensure your system is optimized. I’m on Gnome myself so I can’t speak for KDE, but generally speaking with certain packages, ie kernel, systemd, nvidia drivers, etc I’ll always do a reboot after those packages are updated to ensure my system is now fully up to date and optimized. Perhaps a component that was updated was responsible for your system lagging and the reboot alone was enough of a solution, I can’t say for certain, but that’d be my first guess.

This paradigm is one of the reasons why Fedora requires certain updates to be installed during a reboot to prevent your system from catastrophic failures. I personally think their approach is a bit overkill, but on it’s merits the idea makes sense, I just don’t find it all that practical for the user to waste so much time installing updates during a reboot when 95% of the time or more things will work out just fine.

EDIT: Use the following if your file-system is ext4, if you use btrfs, DO NOT use the following as it is unsupported.

So, if you want to enable the grub so that on boot it selects by default whichever kernel you last used, then please follow these commands:

Source: (What kernel do you use? - #31 by Scotty_Trees)

Open a terminal and run:
sudo nano /etc/default/grub

You have to change two values here. First at the very top look for (use the arrow keys to go up and down in the nano editor btw):

GRUB_DEFAULT=0

And change the value from a 0 to “saved” without the quotes like the following:

GRUB_DEFAULT=saved

Next value to change, look for the following (it’ll be towards the very bottom):

# Uncomment to make GRUB remember the last selection. This requires

# setting 'GRUB_DEFAULT=saved' above.

#GRUB_SAVEDEFAULT=true

Here, get rid of (aka delete) the “#” (hashtag) before GRUB_SAVEDEFAULT=true
Normally we call this commenting or uncommenting with the hashtag # to indicate when a value is being used or not.

So it looks like the following:

# Uncomment to make GRUB remember the last selection. This requires

# setting 'GRUB_DEFAULT=saved' above.

GRUB_SAVEDEFAULT=true

Now you may hit Ctrl+X, then type Y (for yes) and hit enter to save the file.

Next you have to ‘reload’ grub with the new vaules, so for that use the following:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Once you’ve done that, reboot, select a different kernel that you don’t normally boot from, login real quick, and do another reboot to check to see if the kernel you previously selected is saved from the last boot and then you should be all good to go!

1 Like

Sorry I actually talked way to fast I removed the LTS thinking that I’m good now! But this made my system go slow again… Definitely a kernel issue for me… The LTS is working fine tho…

Yea no worries, sticking with an LTS kernel is honestly recommended, so you can’t go wrong with it. The only time you really need the latest (5.14) kernel is for very new hardware support or you want to test/report bugs to the maintainers. Other than that, hope your system is good and enjoy using EndeavourOS :slight_smile:

I just reconfigure the grub! So good thank you that worked perfectly!
Very weird but yes I reconfirm that the 5.14 does work with LTS installed without it. It’s laggy thanks again have a fantastic day!
Edit nope the new kernel doesn’t work even with LTS so I will just switch and keep LTS… Thanks!!!

1 Like

@hsdredgun There must be something else you’re running on your system that is slowing down the workflow on your machine.
My IdeaPad with AMD Ryzen 5 4600U and the same Renoir graphics, also with 16 GB RAM runs the mainstream kernel without any issues.

It must be something that you are running in the background that has issues with the latest kernel. This really is worth investigating.

1 Like
journalctl -b -0 | eos-sendlog

would may give us a hint if something else is causing the issue…

1 Like

Sorry my bad I thought I fixed it but absolutely not its very laggy here are the log:

https://clbin.com/aCMfG

I also got those one with the help of your tutorial thanks a lot! http://ix.io/3yyn

@joekamprad Does this issue has to do with r8168 being installed? I know that ThinkPads are running Intel wifi cards.

@hsdredgun You can remove r8168 by sudo pacman -R r8168 Then reboot your machine, I’m not completely sure if it will solve the issue, but you don’t need it either.

1 Like