External SSD not showing as a choice on installer

I have an external SSD (shows up as a removable USB device) that I want to install EOS on.

My issue is that when I try to go through the installer, I do not see it as an option to install the OS on. I only see the internal storage devices on my PC (2 NVMe SSDs, and a HDD). I know that EOS does recognize my external SSD since it does show up at the bottom right of the screen and I am even able to open it. I tried reformatting it multiple times through Etcher on windows 10 (I believe it was ext4 first, then made it NTFS and lastly FAT32). None of my solutions worked.

I consider myself pretty new to Linux overall so perhaps I missed a step along the way (I did install Ubuntu on the same SSD before, but I did reformat it and completely removed it before trying to install EOS)

I did read somewhere that I had to enter some sort of parameter into the Kernal in order to allow it to use removable storage devices from some other post online, however I honestly have no idea on how I would even do that.

Specs:
Ryzen 5 5600x
RTX 4060
500 GB NVMe
1 TB NVMe
2 TB HDD

Latest EOS iso

1 Like

You mean when the system has been booted from the install media?
Could you PLS post the output of lsusb and lsblk -f ?
[edited]

Yes, I had EOS on a flash drive (not the same as the SSD I wanted to use for EOS)

Output for lsusb:
"
[liveuser@eos-2024.01.25 ~]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0781:5575 SanDisk Corp. Cruzer Glide
Bus 001 Device 003: ID 05ac:024f Apple, Inc. Aluminium Keyboard (ANSI)
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 005: ID 048d:5702 Integrated Technology Express, Inc. RGB LED Controller
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID b58e:9e84 Blue Microphones Yeti Stereo Microphone
Bus 003 Device 003: ID 046d:c547 Logitech, Inc. USB Receiver
Bus 003 Device 004: ID 2357:0604 TP-Link TP-Link UB500 Adapter
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 002: ID 17ef:455c Lenovo Lenovo PS8 Portable SSD
"

Output of lsblk -f:
"
[liveuser@eos-2024.01.25 ~]$ lsblk -f
NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS
loop0 squashfs 4.0 0 100% /run/archiso/airootfs
sda
├─sda1
└─sda2 ntfs 5E2A00B32A008A6B
sdb iso9660 Joliet Extensi ARCH_202403 2024-03-01-15-06-37-00
└─sdb1 vfat FAT32 PS8 7C04-DE00
sdc iso9660 Joliet Extensi EOS_202401 2024-01-25-18-25-14-00
├─sdc1 iso9660 Joliet Extensi EOS_202401 2024-01-25-18-25-14-00 0 100% /run/archiso/bootmnt
└─sdc2 vfat FAT16 ARCHISO_EFI 8093-0377
nvme1n1
└─nvme1n1p1
ntfs 5A2E4CAC2E4C82CD
nvme0n1
├─nvme0n1p1
│ vfat FAT32 085A-FFF7
├─nvme0n1p2

├─nvme0n1p3
│ ntfs 7C5C5C5F5C5C15EC
└─nvme0n1p4
ntfs 08EE7D4FEE7D35D2
"

The Lenovo PS8 SSD is the device I would like to install the OS on.
The SanDisk Cruzer Glide contains the install media.

Trying to get this straight, PLS use “Preformatted text” option for future outputs:
sda is the internal HDD?

EDIT:
sdb appears to be the media you want to install on:

sdc is the EndeavourOS install media you booted from.

I think the installer doesn’t see the Joliet ISO 9660 type of the Lenovo SSD as install-worthy.
Any particular reason why you choose to use Etcher to format the SSD?
EDIT2:
By any chance, did you try to put the install media on this ssd first?

Ah my bad I just found out about the preformatted text option, thought the quotes would do it.

I am pretty sure sda is the internal HDD since everything else is in NVMe. Yes sdc is the flash drive with the install media. Yes sdb is the SSD is the media I wanna install on.

No I did not try putting the install media on the ssd first. Should I try?

As for why I used etcher, honestly I just saw people recommending it so i tried it (worked fine for ubuntu) If you have other recommended software I could give it a try I don’t mind. thanks

No, this doesn’t make any sense.
I was wondering why your SSD is a ISO 9660 which typically is for (nowadays) installation images and back then was for CDs and DVDs.
I tried to recreate your problem and found out I can’t install on all the USB ports on my system (old laptop).
I.e. I switched ports and only then the device showed up in the installer’s pull-down menu.
Maybe try a different port on another bus for the target ssd?
lsusb should give you an idea.

Tried a couple of USB ports including the ones at the front of my PC. Nothing worked.
Do you think changing the SSD ISO thing to a more modern version would solve it? If so how could I go about it?

Maybe you did, by mistake:

I am not sure if Etcher is the right tool for formatting drives.

You can try creating a new GPT partition table on that drive.

:warning:
Be very careful to pick the right drive.
Creating a new partition table will wipe all data on a drive so be careful.

Oh sorry! I meant I used some program, I think it was called MiniTool Partition wizard to format that SSD. Etcher was only for the install media, my bad.

When booted into the install media, does the SSD you want to install on (sdb?) show up in the KDE Partition Manager?
Launch that via the main menu.

Ah, thank you. I just did the partition table in GPT format and left it allocated. I then closed and started the installer again and now it shows up as a choice. Thanks!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.