External Monitor does not automatically become primary when laptop lid is closed


After updated my system today (sudo pacman -Syyu) I noticed that my external monitor behavior has changed with my laptop.

Previously with my external monitor connected via the display port of my laptop (Thinkpad T450), when I closed the laptop screen my external monitor would automatically become the Primary Display and latop built in screen shut off. This means my login screen would automatically shift to the external monitor.

Presently ith my external monitor connected via the display port when I close the laptop screen, it appears to:

  • Built in screen stay on.
  • Login Credentials (GDM) stay on the laptop built in screen and do not shift to the external monitor.

To Troubleshoot:

(1) I verified I could manually make the external monitor the primary screen using the Gnome Display settings.

(2) With no external monitor attached the laptop automatically suspended when I closed the lid.

(3) I reviewed the " /etc/systemd/logind.conf" file for configuration changes:

# Use 'systemd-analyze cat-config systemd/logind.conf' to display the full config.
# See logind.conf(5) for details.


This is the system configuration:

  Kernel: 5.15.25-1-lts x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-lts
    root=UUID=715c2972-1a51-4d73-89a0-86ea7bb5aa7f rw
    resume=UUID=715c2972-1a51-4d73-89a0-86ea7bb5aa7f resume_offset=36151296..
    apparmor=1 lsm=landlock,lockdown,yama,apparmor,bpf
  Desktop: GNOME 41.4 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: v: ThinkPad T450
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 
    serial: <superuser required> UEFI: LENOVO v: JBET73WW (1.37 )
    date: 08/14/2019
  Info: model: Intel Core i5-5300U bits: 64 type: MT MCP arch: Broadwell
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2295 high: 2296 min/max: 500/2900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2296 2: 2295 3: 2295
    4: 2295 bogomips: 18358
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx

  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
    ports: active: HDMI-A-1,eDP-1 empty: DP-1,DP-2,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:1616 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 2-8:4 chip-ID: 04f2:b449 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: with: Xwayland v: 22.1.0
    compositor: gnome-shell driver: X: loaded: intel
    unloaded: fbdev,modesetting,vesa gpu: i915 display-ID: 0
  Monitor-1: HDMI-A-1 model: HP E243i serial: <filter> built: 2019
    res: 1920x1200 dpi: 94 gamma: 1.2 size: 518x324mm (20.4x12.8")
    diag: 611mm (24.1") ratio: 16:10 modes: max: 1920x1200 min: 720x400
  Monitor-2: eDP-1 model: LG built: 2014 res: 1920x1080 dpi: 158 gamma: 1.2
    size: 309x174mm (12.2x6.9") diag: 355mm (14") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2)
    v: 4.6 Mesa 21.3.7 direct render: Yes
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.25-1-lts running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.47 running: yes

  Processes: 184 Uptime: 19m wakeups: 3 Memory: 15.51 GiB
  used: 1.94 GiB (12.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: 1556 pacman: 1531 lib: 484 flatpak: 25 Shell: Zsh
  v: 5.8.1 running-in: tmux: inxi: 3.3.13

Possibly this bug in upower:


Apparently I choose the wrong day to run my upgrades. Thanks for pointing this out.

I did confirm the solution of downgrading the upower packages on my Thinkpad and Acer laptops fixedtge isdue.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.