External keyboard left shift + ctrl has some linux action which i cannot figure out

So today I wanted to use an external keyboard and was working in vscode. As a habit I always use left ctrl + left shift + P for command center. But to my surprise it wasn’t being registered so I dug around a little and found https://stackoverflow.com/a/63869033. So the same shortcut is working with right shift. Then I tried xkeycaps/xev and except for left ctrl+left shift+p every other combination of left ctrl+left shift+ [alphabet] is working. The problem here is I am using i3 and none of my keymaps have ctrl+shift combination for vscode to not recognise unlike the user in the stackoverflow post where gnome has the combination configured.

With laptop keyboard left ctrl+left shift+p is working. xev shows same keycode for internal and external left shift. How do i debug here?

Similar issue but I am still unable to figure out the problem

Using xkeycaps first few seconds were with the built in laptop keyboard, The next few seconds is with the external keyboard where left ctrl+ left shift were registered but not the p when i press left ctrl+left shift+p

Any idea where i can start digging? I tried remapping left ctrl and left shift to their respective right modifiers but the problem still exists. I tried remapping with https://github.com/sezanzeb/input-remapper which did remap but this specific combination is still not being registered.

Hi guys,
I also have the same issue I usually use left shift + “=” for the addition symbol but can’t do that but while using with the right shift it works fine what is issue I can’t figure it out

I am using logitech wireless keyboard

post deleted