External HDD can't be mounted

I have 2 external HDDs connected to my desktop computer, 1 for data, 1 for movies. Since a week or so the PC doesn’t recognize the HDD anymore. I can see it in GParted but can’t do anything with it. Since there are many good movies on that platter I don’t wanna format it.

I already switched out the cable, put it in another port, tried it on 2 laptops … no joy. :frowning:

Anyone got any idea how to remedy the situation, please?

Thankies :woozy_face:

Sounds a little bit like a physical problem on the HDD, as you have already tried the most obvious easy tricks.
Some things come to mind though (which however may not help…):

  • does the disk need an additional power cable?
  • have you shut down the computer and waited for e.g. 30 minutes, and then plugged all in?

And can you show what you see with gparted? Does it show all the partitions what you have created?

If you happen to get it working again, I’d recommend backing up everything you’d like to keep, since the disk may be failing.


As @manuel said it seems to be a hardware problem.
Try from a live USB!?
Can you in Gparted try to resize the disks? (just try but do not really do it.
I just thought, maybe trying a new case might help!
We still have hope as you could see it in Gparted.

1 Like

in the case the HDD’s are seen in GParted, I would like to try mounting them manually ( mount -a )
or have you done it already ?

1 Like

@ Manuel: the discs are USB powered, plug n play, no extra power brick needed. The computer is often shut off for hours and hours, still no joy.
What I see in Gparted:

No idea why it says ntfs, should be ext4.

@ limotux: Live USB? No. But I tried it on 2 different laptops as well. Same problem. :frowning:

@ colin: just type mount -a in terminal? Or is that part of a longer command? I’m a doofus in terminal. :frowning:

oups - a ntfs partition is not known by linux

suggestion: if you have a windows OS anywhere, try there to open the HDD

1 Like


A ‘last resort’ of kinds…


Read this and see! https://www.makeuseof.com/mount-ntfs-windows-drives-in-linux/

Have you tried on a windows machine?

If the partition should be ext4 and it shows ntfs, then something is not right.

And there’s the exclamation mark inside the triangle, which means some warning.
Can you right click the triangle to see if there is more information?

Edit: if you are sure it should be ext4, you could try mounting it manually, something like:

sudo umount /dev/sdb1    # if needed
sudo mount -t ext4 /dev/sdb1 /mnt

Does that latter command give any me messages, or does it work?

Note that your /etc/fstab might have some line using /dev/sdb1 …

1 Like

Got rid of Windows in 2013, have destroyed my DVD. :angry:
And the pladder worked until a couple days ago. It’s all so weird.

Won’t that delete my system as well?

This is what I get:


It’s sounds all Alien to me. :alien:

So it is not ext4 afterall?
Does command

LANG=C sudo mount /dev/sdb1 /mnt

work any better?
Please show the output of

LANG=C df -hT
LANG=C sudo fdisk -l


1 Like

As far as I understand from the link, NTFS is not supported by default. You need to install a driver to be able to read NTFS.

I hope this helps.

looks to me the HDD is destroyed or partition is damaged
(or really in ntfs so that linux can’t read it)

The image OP posted says it is NTFS!
So, OP needs to install drivers to handle NTFS

1 Like

Maybe your ntfs-3g was damaged, try to reinstall it and see what happens.
sudo pacman -S ntfs-3g

It seems to me your partition is a ntfs partition.
As far as i know, if a ntfs partition is damaged and any linux os can not mount it, only win-10 can fix it.
I have done this many times.


Perhaps you could post the terminal output as text instead of an screenshot.
It make it easier then to copy, paste, quote etc…
It will also be searchable by the forum search function.
Just copy, paste, highlight and press Ctrl-E to format.

1 Like

I checked and found it installed on my system.

1 extra/ntfs-3g 2022.10.3-1 (550.9 KiB 1.6 MiB) (Installed)
    NTFS filesystem driver and utilities

So maybe uninstall and reinstall.

Nah nothing to do with that.

Linux can read and write to NTFS. Where do you get your news from?

1 Like