Extended screen. for dual monitor

hii, i have 2 monitors, how to extend it… right now it is in clone; both displaying the same thing. i just can’t find the “extend” mode.

thx.

From previous posts, I think you are using plasma, so I’m running with that.

It should be system settings>hardware>display and monitors. Here you can set resolution and position of each. You will also want to disable “unify outputs” this is what will make them mirror each other instead of extending the desktop between them.

2 Likes

yes, plasma
i can’t find the “hardware” you mentioned. this is system settings… display configuration. this is where i adjust my 2nd monitor to be on top of laptop monitor… but no extend. i have bin here before… i also suprise why the extend button is not grouped here … with the rest that are relevent.

i got several settings that are not same as descripted , i think my plasma is somehow not exactly same as other ppl… maybe lasted version ?

currently my laptop original screen is blank… i don’t know since when something have being changed? but it is blank now… i need to make it work too…

Try plugging the second monitor in and out, and even rebooting, as Plasma sometimes is a bit finicky when it comes to connected divices.

I’ve had some related sound problems…

How did you get it to clone? I don’t see any settings other than this is your primary monitor now. The setting were maybe there when you first set it to clone? This is really not a settings issue but rather a hardware issue. So disconnect the secondary monitor and go back and set up the primary. Then once it is setup then try connecting the secondary display. You may need to use other tools such as xrandr to set it up. All hardware is not equal.

1 Like

good idea. i tried to uplug the 2nd monitor, and indeed the laptop screen got display… but sadly, when i plug the 2nd monitor, the laptop screen blank again.

by default it is cloned (that’s windows os term, simply means duplicated, or mirrored).
i have not find the extend monitor button. and my laptop screen still blank as long as 2nd monitor is plugged.

not fix yet.

What is in the scroll box when you plug in that other monitor. I see Device laptop screen. What is in the box if you click on it.

c62da16fdb21d663dc998b14197817d154578f47_2_690x388

thanks for your help. i got my laptop monitor back online. somehow the "enable " button was unticked… i swear i didn’t untick it… some bug that causes it to be unticked… or some keyboard combination is to untick laptop monitor…

and most wonderful weirdest thing is , my both monitors are now in “extended” mode already, no longer in “clone” … !! i have trying to get it to extend for so long, never able, now it auto get it “extended” … that’s what i meant by plasma is buggy… flip flop… a moment like this and another moment like that.

so i don’t have a clear solution to this fixed thread… :upside_down_face:

I don’t know if it is so much buggy? For me it is a lack of understanding some of the controls or features and how to enable or disable stuff. I’m more used to Cinnamon. But i do use Xfce and Plasma as well as others. Just not as familiar with them.

Edit: The main thing is it’s working for you! :wink:

1 Like

what i fear most is that, what if it happens again ? like it goes back to clone mode instead of extend… and disturbed me from working… then i will have to post a new thread again :sweat_smile:
because the root cause was not located.

now my mouse scroll button no longer work!! oh man!.. this is crazy. it was working fine a moment ago (before monitor extended mode)… this os is … buggy! crazy , it is alive ! :rofl: oh. man i can only make joke to keep myself from upsetting. lol

Go into system settings and check input devices.

Edit:


no mouse pad ?

i have switches all options and applied and back to original again…

my scroll button still not working.

even thoug no mousepad in the "hdarware> input devices " but my mousepad works fine, 2 finger scroll also works…

so, whats next ?

Do have mouse but just no scrolling?What about scroll on the mouse pad?

Edit: I think what you should do is mark this a solved for the Extended screen and create a new post for this scrolling and touch pad issue. Someone who has more experience with this on KDE should be able to help. It probably is more related to some .conf file or libinput or evdev or something. I don’t think it’s just a setting to change.

Things are ever changing on my plasma, really!
Touch pad was not on the list, now it is . It just appears.
Touch pad scrolling are working… Touch pad is all functioning well now. All the settings options are there.
My mouse was scrolling well, until it just out of sudden not scrolling anymore.
I have restarted my computer twice (a few mins ago)… and now, my laptop screen gone blank again (after i “enabled” it just now, before reboot).
This is the reason why i said plasma was buggy… and flip floping.

Correction! Laptop screen was set to dimmest, when booted up. I press hardware key combo (default with my laptop), the laptop display is back again.

1 Like