Ext4: read only file system?


I have moved to EOS from mx linux. After installing some packages and setting up I’m trying to run timeshift but it says:

[17:17:21] E: Error creating directory /run/timeshift/46575/backup/timeshift/snapshots/2023-10-08_17-17-21: Read-only file system
[17:17:21] E: Failed to create directory: /run/timeshift/46575/backup/timeshift/snapshots/2023-10-08_17-17-21
[17:17:21] E: Error creating directory /run/timeshift/46575/backup/timeshift/snapshots/2023-10-08_17-17-21: Read-only file system
[17:17:21] E: Failed to create directory: /run/timeshift/46575/backup/timeshift/snapshots/2023-10-08_17-17-21/localhost

i don’t know why the sd card has become read only and the owner is root. I tried changing owner as they describe here but it gives response ‘read only file system’ and the owner is still root. The file system is ext4 -why would this be considered a read-only file system for the sd card and not the internal drive? I could install gparted and just reformat the sd card but i have some old mx linux snapshots on there taken before i switched to eos. Any idea how to proceed? thanks

Sd cards usually have a little slider on the side that will make them read only. Make sure you didn’t accidentally trigger this. If that is not the case, then try remounting the card as read write from the terminal.

1 Like

thanks. Unfortunately it’s a micro sd card with no slider. I have been searching online and the problem seems too complicated for me, eg Micro SD card automatically mounted as read-only on Linux and SD card read only - how to make it writeable? For someone with my abilities i think the solution is to buy another flash drive. I can’t even eject it safely, i just put the computer to sleep and removed it

All of that is way too complicated and I have no idea why they are doing any of that. I meant something more like sudo umount sd card and then sudo mount -o rw /sdcad /mount_path I don’t know the exact commands off the top of my head. You’ll have to Google them. Something like remount partition as read-write.

1 Like

many thanks, that worked. In case any other noobs someday read this, these are the commands i used:

lsblk -fp [to see the path: /dev/sdf1]
sudo mount -w /dev/sdf1 /run/media/[user]
sudo chown -R [user]:[user]/run/media/[user]/timeshift  

then the owner was changed and timeshift ran easily

edit: i should add, to remove the sd card i did:

umount /dev/sdf1
sudo eject /dev/sdf1
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.