Expo Go only works if the firewall is turned off

I’m testing a react native app on my android phone with Expo Go. Everything works fine, I scan the QR code with my phone but it only builds the app, when the firewall on the PC is turned off. I also tried alternative solutions like: tunelling, changing some settings on the phone. I don’t really want to turn off the firewall on the system, does anyone know what service needs to be allowed in order to let the connection pass through?

It looks like expo go uses a different port for each application you create starting with 19000. You will probably need to add a service for whatever port that the application is using.

It probably tells you what port it is using when it starts the application. The port should be in the url after the :

I added the port with every protocol to the services, but still doesn’t work. (The port is 19000)
Screenshot from 2022-08-16 21-24-07

That just creates the service. You then need to enable it in your zone by checking it off. You might need to reload the firewall from the menu for it to show up.

The zone you are currently using should be in bold on the list.

1 Like

Thanks it works now. Something is still odd. If the service is added to the Zones it does not work, only if the port is added to the Ports section.

But it makes sense, no?!

If the port is already specified in the service and the service is added to the Zones, I don’t see the necessity to specify the port separately. I just don’t get it…

I see. It may depend on the firewalld-gui in use?

Oh it actually works, I didn’t restart the firewall after adding the service. It’s enough if the service is enabled. Sorry for not being attentive.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.