Experiencing Choppy Audio for a few seconds and then it works but the sound pops every few seconds and the quality is wierdly tinny, also missing system volume icon

Context

  • It worked mostly fine (there was an issue, see issues section)
  • Then I broke it by me getting muddle-headed and uninstalling a bunch of pipe-wire related packages, I’m a bit scatter-brained and I wasn’t sure if I was running pipe-wire or pulseaduio and made a bad-assumption
  • I reinstalled pipe-wire and friends
  • I didn’t begin experience the issues mentioned in the title until after I tried to fix what I broke
  • I have pipe-wire running again, I’ve tried to remove everything pulse-audio related that needed to be removed

Issues

  • Original issue that still persists: If I try to watch any video in any web-browser (FireFox, steam store page via chrome, etc) with my headphones the sound plays but the video is like a slide-show with a frame every few seconds, then it locks up, the problem goes away if i mute the sound or switch to my blue-tooth sound-bar, movies (E.G. intro cinematics) in games however worked fine, Incidentally, this specific issue went away with “PuleAudio”
  • New sounds comes out all garbled and takes a few seconds to smooth out
  • I can hear a pop or hitch in the sound every few seconds
  • Sound quality is now bad, is tinny and can hear strange subtle (very subtle indeed) distortion (I honestly can’t describe it)
  • System volume icon is missing and I can’t find the name of it’s package to re-install, found a package called volumeicon but I’m pretty sure it’s not the same (different right click properties, not the same volume mixer, etc) as the EOS volume icon

Additional Context

  • I did find this issue about “Audio being choppy for a few seconds” but my system’s fTPM has been disabled since day one (and as I said I had no sound quality issues before)
  • I also found this issue about “missing audio icon” but I do have sound and alsamixer works fine

Log Outputs:

I think that’s everything?

Just to be sure about pipewire and friends, that’s:

sudo pacman -S pipewire pipewire-pulse pipewire-alsa pipewire-jack wireplumber

right?

Sorry, this may or may not be helpful. About 5 minutes ago I was fixing an audio issue on my newly installed EndeavourOS and during my hunt for a solution I came across this troubleshooting guide (linked below).

You might find it a little easier to narrow down the source of the problem by using alsamixer in the terminal - it certainly helped me just now. It’s pre-installed, just type “alsamixer” to run it.

https://wiki.archlinux.org/title/PulseAudio/Troubleshooting

Good luck!

yes

I have seen this, but I wasn’t sure if it was actually helpful to my circumstances, since that page was for PulseAudio, not pipe-wire, though perhaps it could be used to fix issues with either?

I find it all a bit confusing to be honest, I fixed my problem using alsamixer. I have pulseaudio and pipewire stuff installed (these were preinstalled with Endeavour) so I actually have no idea whether pulse-audio or pipewire or both are doing stuff.

When I did fix my audio problem (getting my phone’s audio output to the line-in at the back of my pc to output through speakers/headphones) I had another problem with dodgy audio - loads of noise and static coming from somewhere - turned out that if I have my phone charging it disrupts the signal from the phone’s nearby headphone jack. So if I use my phone to play audio through my pc I can’t charge it at the same time.

Sorry I cannot be of more help, I am very new to this stuff.

1 Like

So installing KDE plasma (I saw an awesome looking icon set) solved the missing volume icon, so at least that’s not an issue any more :stuck_out_tongue:

I fixed the sound issue by copying a pipewire config to ~/.config/pipewire/ and then setting default.clock.rate = 192000., I think the sound issues was due to the sampling rate being set to some weird value, still haven’t solved the head-phone issue… but at least things are back to square one :P.

EDIT: ok, it’s now not working again, don’t know what I did to cause it.

1 Like