Ethernet suddenly won't connect

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 26)
Subsystem: ASUSTeK Computer Inc. Device 87c3
Flags: bus master, fast devsel, latency 0, IRQ 35, IOMMU group 22
I/O ports at f000 [size=256]
Memory at fc704000 (64-bit, non-prefetchable) [size=4K]
Memory at fc700000 (64-bit, non-prefetchable) [size=16K]
Kernel driver in use: r8169
Kernel modules: r8169

seemingly stopped working after sometime after updating to 5.16. running zen kernel, had same issues in vanilla. swapping to 8168 didn’t seem to work either

Welcome to the forum! :smile:

I assume this is a kernel regression that will be fixed soon.
Did you try the LTS kernel already?

you know i kinda figured this was the case after trying a few different fixes and this happening very shortly after 5.16 dropped. not the first time running into this bug. i don’t have lts actually just vanilla and zen. i was using RT but swapped after finding that zen actually seemed to perform better and then 2 days later i lose ethernet lol. i’ll install lts and see if that’s where the problem lies.

hmm same issue on LTS as well


went back to zen and just ran sudo modprobe 8169 and got the following “FATAL: Module 8169 not found in directory /lib/modules/5.16.0-zen1-1-zen”

I have it:

Maybe the install of linux-zen did not go well?

sudo pacman -Syu linux-zen linux-zen-headers

went into /lib/modules/5.16.0-zen1-1-zen/kernel/drivers/net/ethernet/realtek/
had the following contents

reinstalled zen+headers and same issue

Welcome to the forum @idiotbusy :partying_face::tada:

Looks like you forgot the “r”?
modprobe r8169

oh yeah oops. without the typo still no change to ethernet. still won’t connect

have you tried r8168-dkms driver?
also, when you tried the lts kernel did you try the r8168-lts driver?

Also, you can read through this thread as well.

ill give it a go, thanks

so i did a bit more testing, following a couple guides and looking around through etc and lib/modules

i tried r8169
made a blacklist.conf with the contents blacklist 8168 in etc/modprobe.d/
if i open EOS welcome the 8168/8169 toggle appears and ethernet connection is recognized and shows up in the network manager but it won’t connect.

i tried r8168
made a blacklist.conf with the contents blacklist 8169 in etc/modprobe.d/
if i open EOS welcome the 8168/8169 toggle does not appear and no ethernet is recognized in the network manager
if run i sudo modprobe r8168 there is no r8168 module in zen to be reached
otherwise my system seems to be running fine. i’ve also seen a few other people running into the same issue post 5.16 so i’m wondering now if i can figure out a fix for this or if i just settle on wifi only for now

tried r8168-dkms but no dice

Note that the r8168 package creates a blacklist file in
which may affect the system…

i’m aware of that blacklist file but i did overlook it initially
currently i’m on r8168 with r8169 blacklisted, recognizing my ethernet connection just not connecting
took a look at a snapshot from last month when my connection was for sure working fine to compare and modprobe.d is empty there, i’m assuming then that i was using r8169 before? the confidence of ending with a question mark

Getting r8168 or r8169 driver with a 8168 card is simple:

  • install package r8168 and reboot ==> now using r8168
  • uninstall package r8168 and reboot ==> now using r8169

So no need for additional blacklists.

With command
lsmod | grep r816
you’ll see which driver is currently in use.

actually it turned out to be a hardware issue in the end. i reset my modem a couple times to see if that was the problem and there was no change. finally i decided to dig up an old laptop with an ethernet port, setup EOS install vanilla and lts see if either worked. no dice. figured out the ethernet ports were the problem so i just rode my bike across the city and got a new modem lol. now i am all good. thank you so much for the advice regardless, i do enjoy any opportunity to dig around in my system and get a better understanding. so yeah thanks!

1 Like

Yeah, hardware problems cannot be ruled out, and this time it seems to be it.
Anyway, great that you figured it out and solved it! :+1:

1 Like