Ethernet on live, install, and once installed does not work

The wireless works but can not have ethernet work. On both live and installed.
I updated and did not. The ethernet (hard wired) did not even show in the network manager both pre and post install on both EOS installs tried.

So I reinstalled the april release (which originally worked fine - both pre and post install).

I have installed other distros like manjaro, arco, and debian… They work fine - live and installed.

If someone knows a list of steps or article directly addressing this work.
This is a 10 year old laptop with plenty of RAM, etc. Intel based.
Read somewhere there may be drivers that arch removed???

Love this distro EOS! light, and vanilla without excesses…

To be clear the april release did not work either, when it did install and have ethernet working previously

Welcome theyoach to the EndeavourOS forums. Thanks for giving EndeavourOS a try. I hope you enjoy your time here.

Did you install the offline XFCE or an online Desktop Environment, and if online, which Desktop Environment?
What does the command
lspci | grep -i network
yield?

What does
systemctl status NetworkManager
yield?
Should see something like this, especially the last line.
● NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disa>
Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
└─NetworkManager-ovs.conf
Active: active (running) since Fri 2020-06-05 11:02:25 MDT; 9h ago

What does
systemctl status | grep -i network
yield?

Here is my systemctl status | grep -i network
│ │ │ ├─10040 /usr/lib/gvfsd-network --spawner :1.19 /org/gtk/gvfs/exec_spaw/1
│ │ │ └─10693 grep -i network
├─systemd-networkd.service
│ └─703 /usr/lib/systemd/systemd-networkd
├─NetworkManager.service
│ └─707 /usr/bin/NetworkManager --no-daemon

that will give us a starting point.

Pudge

Thanks pudge!!! Unfortunately I am programming a site and in a day or so can give u a response if need be. Need to install again.

But that makes sense what shared…

I was just wanning to make a fully installed xfce as I like and use with tweaks and all and original win managers (xMonad and bspwm) like want and then clone… Like the base arch way…

Appreciate the start!

1 Like

Not sure if was clear…
The live EOS iso would not show nor connect to ethernet also. But wireless did

But will start what shared.
Thanks again

1 Like

@theyoach
If the Ethernet is not working on the live ISO as well as installed we need to see what the network hardware is. Could you post inxi -FGz

Thanks.

1 Like

System: Kernel: 5.6.11-arch1-1 x86_64 bits: 64 Desktop: Xfce 4.14.2
Distro: EndeavourOS 2020.05.08
Machine: Type: Laptop System: Hewlett-Packard product: HP G62 Notebook PC
v: 0496110000202710000620000 serial:
Mobo: Hewlett-Packard model: 1425 v: 54.27 serial: BIOS: Hewlett-Packard
v: F.17 date: 07/05/2010
CPU: Topology: Dual Core model: Intel Pentium P6000 bits: 64 type: MCP L2 cache: 3072 KiB
Speed: 1112 MHz min/max: 933/1866 MHz Core speeds (MHz): 1: 931 2: 946
Graphics: Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel
Display: server: X.Org 1.20.8 driver: intel unloaded: fbdev,modesetting,vesa
resolution: 1366x768~60Hz
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio: Device-1: Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.6.11-arch1-1
Network: Device-1: Realtek RTL8191SEvA Wireless LAN driver: rtl8192se
IF: wlan0 state: up mac:
Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: N/A
Drives: Local Storage: total: 316.26 GiB used: 44.07 GiB (13.9%)
ID-1: /dev/sda vendor: Samsung model: HM321HI size: 298.09 GiB
ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer U size: 14.61 GiB
ID-3: /dev/sdd type: USB model: Flash USB Disk size: 3.56 GiB
Partition: ID-1: / size: 10.00 GiB used: 59.0 MiB (0.6%) fs: overlay source: ERR-102
Swap: Alert: No Swap data was found.
Sensors: System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 160 Uptime: 11m Memory: 3.65 GiB used: 816.4 MiB (21.8%) Shell: bash
inxi: 3.1.00

lspci | grep -i network
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvA Wireless LAN Controller (rev 10)

systemctl status NetworkManager

NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabl>
Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
└─NetworkManager-ovs.conf
Active: active (running) since Fri 2020-06-05 22:25:38 PDT; 6min ago
Docs: man:NetworkManager(8)
Main PID: 662 (NetworkManager)
Tasks: 3 (limit: 4441)
Memory: 15.8M
CGroup: /system.slice/NetworkManager.service
└─662 /usr/bin/NetworkManager --no-daemon

Jun 05 22:30:01 archiso NetworkManager[662]: [1591421401.7758] dhcp4 (wlan0): option subnet>
Jun 05 22:30:01 archiso NetworkManager[662]: [1591421401.7758] dhcp4 (wlan0): state changed>
Jun 05 22:30:01 archiso NetworkManager[662]: [1591421401.7781] device (wlan0): state change>
Jun 05 22:30:01 archiso NetworkManager[662]: [1591421401.8186] device (wlan0): state change>
Jun 05 22:30:01 archiso NetworkManager[662]: [1591421401.8190] device (wlan0): state change>
Jun 05 22:30:01 archiso NetworkManager[662]: [1591421401.8198] manager: NetworkManager stat>
Jun 05 22:30:01 archiso NetworkManager[662]: [1591421401.8227] manager: NetworkManager stat>
Jun 05 22:30:01 archiso NetworkManager[662]: [1591421401.8229] policy: set ‘BNANZA’ (wlan0)>
Jun 05 22:30:01 archiso NetworkManager[662]: [1591421401.8273] device (wlan0): Activation: >
Jun 05 22:30:02 archiso NetworkManager[662]: [1591421402.2406] manager: NetworkManager stat>
lines 1-22/22 (END)

systemctl status | grep -i network
[liveuser@eos-2020.05.08 ~]$ systemctl status | grep -i network
│ ├─1238 /usr/lib/gvfsd-network --spawner :1.7 /org/gtk/gvfs/exec_spaw/1
│ └─1525 grep -i network
├─NetworkManager.service
│ └─662 /usr/bin/NetworkManager --no-daemon

1 Like

And thankyou!!!

https://aur.archlinux.org/packages/r8101-dkms/

driver is only available from AUR… could be that there was a version on Repository some times before…

1 Like

the r8168 is not in use ? pacman -Qs r8168

sounds weird…cannot give a source info lost the conversation somewhere…

if its show up; modprobe -r r8168 && modprobe r8169 and restart the networkmanager , systemctl restart NetworkManager

this is temporarely…otherwise should be a reason worked on usb then later not on installed system.

I have a Lenovo Z510 with the Realtek RTL810xE PCI Express ethernet chip. It requires the r8169 driver. Endeavour OS installs Realtek r8168 and that installation blacklists r8169.
https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/r8168#n40
If your system ethernet card needs r8169 you can:
Keep editing /usr/lib/modeprob.d/r8168.conf to comment out the blacklisting of r8169. It gets added with every update of the r8168 driver.
Or:
Uninstall r8168 and that will remove the blacklisting.

sudo pacman -Rsn r8168

and then reboot.

Also see: Why is r8169 blacklisted?

Every time I reinstall EndeavourOS I do the online install via WiFi and then uninstall r8168 on first boot.

2 Likes

i do completely forget about this :wink:

I truly thank you all for the inputs…
Will proceed as need seems…
It was strange that fine for a time when would reinstall EOS and works then one day…

Like the OS and will keep the word of it out there… Have saved several friends old computers us this arch…

Thank you all

Thanks for this. After updating Zen kernel, ethernet hadn’t been working, and removing r8168 fixed it great! :slight_smile:

Had the same problem.I didn’t face this issue in previous iso files.In live USB of may release I had to remove r8168 and then issue modprobe r8169 in terminal to get internet. In installed system has to remove r8168 and restart.Now it is working well.