Ethernet not detected driver r8169

I updated my Windows partition and now my Endeavor OS partition won’t detect my Ethernet. I don’t have Internet on my PC now, so I can’t copy and paste and am typing on my phone.

inxi -Na
reveals I have a Realtek RTL8125 with driver r8169, vendor MSI, chip-id 10ec:8125

I don’t have a file named r8168.conf or r8169.conf in my /usr/lib/modprobe.d/ directory.

How do I get my Ethernet detected?

You aren’t able to show the output?

Edit: The r8169 is a kernel module. The r8168 is a package you have to install.

inxi -Na

Device 1: Realtek Rtl8125.  vendor: Micro Star MSI driver: r8169
v: kernel PciE: gen: 2 speed: 5 GT/s lanes: 1 port:f000 bus-ID 2a:00.0
chip-ID: 10ec:8125 class-ID: 0200

I am able to show the output by manually copying it typing on my phone

It shows that the module is loaded. :thinking:

Edit: Can you boot into Windows and do you have ethernet? I would suggest to disable the fast startup feature under Windows power management.

I can boot into Windows and my Ethernet is working there. Windows won’t let me turn off fast startup - the checkbox is Grayed out

Edit: turned it off just had to give administrator permission

Yes it will you have to click on the left side under change settings that are currently unavailable.

After turning off fast startup and re-entering my Endeavor OS partition, Ethernet is still not detected

All my issues with Linux have been caused by my Windows partition :stuck_out_tongue_closed_eyes:

Well I’m not sure other than that. Fast startup feature enables hiberfile so turning it off makes sure it’s not using that on Windows when you boot into EndeavourOS. Updating Windows shouldn’t change anything for the ethernet on EndeavourOS. It uses a kernel module.

Edit: Also the module is loaded. So not sure why your network connection isn’t showing up?

Is there a way to restart the module

You can try

sudo rmmod r8169

sudo modprobe r8169

That didn’t appear to do anything…

What is the hardware since you have no internet? Is this a laptop? Desktop?

inxi -Fz

It’s a desktop

Ran inxi -Fz, got too much to type on my phone. It does say the Network device is down.

Device-1: Realtek Rtl8125 2.5GbE driver: r8169
IF: enp42s0 state: down Mac: <filter>

I need more info such as what is the motherboard?

Edit: Can you try booting on the live ISO and see if ethernet works? If it does then post the following.

inxi -Faz | eos-sendlog

Live ISO Ethernet not working

Mobo is MSI MAG B550M mortar (MS-7C94)

You can also after boot into endeavouros and check the network status

systemctl status systemd-networkd.service

See if it’s disabled?

Then restart the networking service

sudo systemctl restart systemd-networkd.service

Your board has the rtl8125B chip and it definitely should use the r8169 kernel module. There is one other package that you could try but you need internet to install it. There shouldn’t be any reason why it’s not working because of updating Windows. My only other suggestion is to power it off. Unplug the tower. Hold down the power button for 30 seconds and then plug it back in and restart the computer. This is usually a problem that happens with onboard WiFi not usually Ethernet but won’t hurt to try it.

So I booted into the live ISO, then went and got dinner, leaving the live ISO on. When I returned I rebooted into my endeavour OS partition and the Internet is working again.
I didn’t touch anything

How could this issue have happened then resolve itself in the first place?

It probably got stuck in Windows somehow? :person_shrugging: