Ethernet isn't showing up

Hi! I just switched over to endeavourOS yesterday and I don’t really have much experience with linux at all. At the moment I’ve run into an issue with my ethernet, it isn’t being picked up by endeavourOS at all. My USB wifi adapter works completely fine out of the box and the ethernet port shows a light so I know it’s connected and it worked fine on windows. But, nothing happens in endeavourOS with it plugged in and it doesn’t show anything in the network settings. It also doesn’t show up when I do ifconfig. my motherboard is an MSI b660m bomber. I’ve tried different card drivers like r8168, r8169 and r8125 but still no dice. My wired internet connection is really unstable and I have a lot of trouble staying connected to calls because of it. The actual router is a bit far from my computer, the router is downstairs while my room is upstairs, I can’t exactly just move the router to my room or closer since my family also wants to use and have decent wifi and most of them are downstairs so I got a wifi extender. Again, it worked fine on windows but I haven’t been able to get it set up on endeavourOS at all these past couple days and I really need it to work. Any help is mega appreciated!

Perhaps inxi -n output would be helpful?

According to the Motherboard specs it is an Intel chip. But please post the output that @dbarronoss has asked for to verify.

LAN Intel® I219-V 1G LAN

Edit: Hmm … looked at the MSI site directly and it shows it is a Realtek chip RTL8125BG 2.5Gbps LAN controller. So yes we need to confirm which chip it actually is on your board.

If it is the rtl8125bg it should be using the r8169 kernel module so you need to uninstall the r8168 package and reboot. If it still doesn’t work we can go from there. But, please also confirm the chip with the command given above.

Edit: Usually the r8168 package if installed blacklists the r8169 module.

it’s possible a service became disabled too, like networkmanager etc.
# systemctl list-unit-files --state=disabled then see if anything looks suspect.

this happens to my linux everytime I update the windows disk and forget to yank the other hdd’s out of the mobo.

can you boot on USB iso Endeavouros
open a terminal and a browser on this topic and return

inxi -Fza