Errors with gpu memory allocation with latest nvidia drivers

Hi, I am facing problem I have never seen so far (using linux with nvidia card for about 5 years now). Every game is crashing with error that it was not possible to allocate graphics memory, but graphics memory is nowhere near exceded. This is the error:
Screenshot from 2023-08-29 23-09-49

and this is state of nvidia card at the moment of the error:
Screenshot from 2023-08-29 23-26-22

Any help please? About a week ago I was playing games with no problem before I updated nvidia packages.

OK–I’m seeing the same sort of problems here…if my system has been running for a while I can try to start Steam & it almost locks the system up…I get weird readings from my Conky display–the card running frequency skyrockets yet the memory frequency drops to 0.

This happened after the update to 535.104…535.98 worked very well. I can reboot the system & Steam will work normally until the system runs for a couple of hours—then the freezing problem comes back.

Looks like I’m going to downgrade. This is when it started:

[2023-08-23T22:31:56-0700] [ALPM] upgraded nvidia-utils (535.98-1 -> 535.104.05-1)
[2023-08-23T22:31:57-0700] [ALPM] upgraded lib32-nvidia-utils (535.98-1 -> 535.104.05-1)
[2023-08-23T22:31:57-0700] [ALPM] upgraded libxnvctrl (535.98-1 -> 535.104.05-1)
[2023-08-23T22:31:57-0700] [ALPM] upgraded nvidia-dkms (535.98-1 -> 535.104.05-1)
[2023-08-23T22:31:57-0700] [ALPM] upgraded nvidia-settings (535.98-1 -> 535.104.05-1)

Kind of late here right now, so I’m most likely downgrading tomorrow sometime. Try running " eglinfo " in a terminal & see if you get a crash…I was on Arch Forums a while ago & that started clueing me into the problem. Make sure you have " downgrade " installed & do:

sudo downgrade nvidia-utils lib32-nvidia-utils libxnvctrl nvidia-dkms nvidia-settings

Just make sure to select the 535.98-1 versions & it will ask you if you want to hold the packages…agree to it.

OK—it was late, but I did it anyway…In short–that “fixed” my problem…will check it again tomorrow to verify. I run BOINC which runs apps on the video card…so if it crashes after all night I’ll know that it is NOT fixed.

It happens to me even after I reboot, start steam and try to play any a little more graphics demanding game. It happens always around 40-50% graphics memory. I will try to downgrade as well and see if problem persists

OK—I ran BOINC all night without a crash…looks like I’m waiting for the next nvidia update.

Glad it was solved for you. Sadly even if I downgraded to 98, I got the error as well. It was working flawlessly a week ago and I have no clue what did happen so now I got that error. Maybe some vulkan update… I don’t know… Also I have done some tests. For example when I run Everspace 2 on epic quality, I can get to like 90% vram usage and no problem. But with Marvel Midnight Suns I got the error around 30% every time

Sorry to hear that…did 535.98 work for you or was it the update before 535.98? You can use downgrade to go back that far. I also remember mesa updates in the past few days also, along with vulcan updates…you could try going back one at a time to test.

Ok, I most likely found what is causing the problems. After some downgrading and upgrading, nothing helped. Then I realized I also updated proton-ge and it seems to be the culprit. With GE-Proton8-13, most of games are crashing with that error. If I switched back to GE-Proton8-12, I have no crashes any more, for example Marvel Midnight Suns as I mentioned earlier (crashed around 30%) now goes up to 80% on epic quality without any issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.