Error with lutris : DRM kernel driver 'nvidia-drm' in use. NVK requires nouveau

Hello everyone, I installed EndeavourOS 3 days ago because my old Windows was really slow (and because I wanted to swap on linux but kept it for gaming).
I tried to figure out issues all by myself up until now but I can’t find anything on this one so I’m asking to you.
I followed documentation of Arch on how to install Lutris, Wine, Steam and other things. I am currently facing an issue when I try to launch Lutris, it displays this error in the terminal :

DRM kernel driver 'nvidia-drm' in use. NVK requires nouveau.

At first it wasn’t disturbing and I managed to launch Epic games without any problem but now, I want to launch Ubisoft connect. It displays the launcher window but when the “Initialization” of Ubisoft is over and it tries to open the login page, the window becomes dark and the PC crashes few seconds afterwards. At the same time, the previous line is again displayed continuously in the terminal.

I tried to check Nouveau documentation on Arch but couldn’t manage to find anything useful. I also tried to check the documentation about nvidia drivers and vulkan and updated the drivers. None of these worked, that’s why I’m asking for advice.

Thank you for your help !

What does pacman -Q | grep -E "vulkan|nvidia|mesa" return?

This command gives the following return :

lib32-mesa 1:24.0.4-2
lib32-nvidia-utils 550.67-1
lib32-vulkan-icd-loader 1.3.279-1
lib32-vulkan-nouveau 1:24.0.4-2
mesa 1:24.0.4-2
mesa-utils 9.0.0-4
nvidia-dkms 550.67-1
nvidia-settings 550.67-1
nvidia-utils 550.67-1
vulkan-headers 1:1.3.279-1
vulkan-icd-loader 1.3.279-1
vulkan-nouveau 1:24.0.4-2
vulkan-tools 1.3.269-1

You need to remove vulkan-nouveau and lib32-vulkan-nouveau

nvidia-utils already provides a vulkan driver.

Thank you, I will try it and update you !

I have a good and a bad news :smiling_face_with_tear:
The good news is the line is not displayed in the terminal anymore.
The bad news is the ubisoft launcher still crashes.
I am currently trying to update wine and use the last version to open ubisoft…

I know this sounds like a lil bit of a stretch, but have you tried using bottles to install ubisoft connect?
To install bottles, you can install via flatpak or by the AUR.

yay -S bottles

Once you install bottles, just create any bottle and go to install programs and scroll to Ubisoft Connect and install it. If you want to stick with Lutris then ignore this, but seeing how you just want to install and use Ubisoft Connect, this could be another option.

I will try this option ! Thank you :smiley:

I tried again this evening with lutris and it seems to be working :+1:
I didn’t do anything special, I just updated everything that had not been updated already and it worked.
Thank you both for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.