Error with Endeavour OS PGP Key Importing

Hi Everyone, I can’t seem to update the system. It fails to import the PGP keys.

I had a similar issue with Librewolf but I ended up skipping the verification check and went ahead with the installation. I know it is not recommended to do this due to security issues.

And now, I am also seeing the same error when updating the system.

(35/35) checking keys in keyring [--------------------------------] 100%
downloading required keys…
:: Import PGP key 003DB8B0CB23504F, “EndeavourOS”? [Y/n] y
error: key “003DB8B0CB23504F” could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

Have you tried updating your mirrors?

I did update the mirror from welcome menu and saved. But no luck.

I did restore my previous backup and then updated without any issues.


main interesting informations missing… what is used to update the system? pacman from terminal yay? any other helper? pamac??

as Librewolf is not using the EndeavourOS key your issue is caused may by something with your keyring.

EOS keyring issue can be solved like so:

sudo pacman-key --add /usr/share/pacman/keyrings/endeavouros.gpg 
sudo pacman-key --lsign-key 497AF50C92AD2384C56E1ACA003DB8B0CB23504F
sudo pacman-key --populate
sudo pacman-key --refresh-keys
sudo pacman -Syy

This will recopy EndeavourOS key back into pacmans keyring.

1 Like

Sorry I should have specified on how I was updating.

I tried both through the welcome app and also through terminal using pacman.

I then just restored my backup from Monday and I was able to update. I will save above for future :+1:t3:

I am doing a clean install to see if librewolf issue is resolved. I followed the arch wiki link to reinstall and refresh the keys but it didn’t work.

Thanks again

I actually found a solution just today that worked after all.

I read many old threads and found a solution with the following:

GPG import key error

Create a .conf file in /home/username/.gnupg with name dirmngr.conf
Add keyserver hkp://
Add standard-resolver
save and close

Note: :80 is for DNS related. If it doesn’t work with 80 then remove and try again by running killall dirmngrin terminal.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.