Error WHILE updating endeavouros-keyring

Hi all!

I’ve got an odd issue. I haven’t used my machine in a while, so my packages are fairly out of date. When trying to update the packages, I got the usual “invalid or corrupted package” PGP errors like I usually do when it’s been a while since updating.

BUT, here’s what’s different. I am getting an “invalid or corrupted package” error WHILE running pacman -Sy endeavouros-keyring:

error: endeavouros-keyring: signature from "manuel <>" is unknown trust
:: File /var/cache/pacman/pkg/endeavouros-keyring-20231222-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y

I have already followed ALL of the steps listed in this article:

Nothing works!

The problem is, /var/cache/pacman/pkg/endeavouros-keyring-20231222-1-any.pkg.tar.zst DOES NOT EXIST when I try to delete it, and running the last command in that article (sudo pacman -U /var/cache/pacman/pkg/{archlinux,endeavouros}-keyring*.pkg.tar.zst) says no matches are found.

What’s going on, fellas?

1 Like

See if the following works:

Set temporarily SigLevel = Never for [endeavouros] in /etc/pacman.conf and run:

sudo pacman -Sy endeavouros-keyring

When/if it get installed, restore the SigLevel = PackageRequired for [endeavouros] and proceed with updating your system:

sudo pacman -Syu


Your clock could be off. In a terminal, type date. Compare it with your mobile clock (go to seconds too)

@pebcak Wow, your solution totally worked. You’re a genius and a saint. Can you explain to me why that needed to be done to get it to work?

And if this still doesn’t work, and you trust that the packages are actually correct and not corrupt and haven’t been interfered with, then you can force (re)installation of the keyring packages:

sudo pacman -U /var/cache/pacman/pkg/{archlinux,endeavouros}-keyring*.pkg.tar.zst

We just disabled temporarily the signature check for that one package to get the keys installed.
A sort of “workaround” somewhat similar to the suggestion in the wiki but since you didn’t have that package in the cache, it needed to be installed from the repo.

Just a reminder:

Glad you got it resolved and welcome to the community @Souper!

PS. please mark the relevant post leading to the solution as such. Perhaps other users facing the same issue in the future will find the suggestion useful.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.