Error while installing app (Cider)

So I’m getting these errors while installing Cider via yay even previously when I tried installing Nuclear had the same error so had to download the Flatpak version but wasn’t satisfied so Tried going with Cider instead below are the errors

[kundan@HP-EndeavourOS ~]$ yay -S cider
:: There are 3 providers available for cider:
:: Repository AUR
    1) cider 2) cider-git 3) cider-minimal 

Enter a number (default=1): 
==> 3
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo Make:4]  nodejs-nopt-5.0.0-2  semver-7.3.7-1  node-gyp-9.0.0-1  npm-8.5.5-1
[Aur:1]  cider-minimal-1.1.0.2120.ad86f58-1

==> Remove make dependencies after install? [y/N] y
:: (1/1) Downloaded PKGBUILD: cider-minimal
  1 cider-minimal                    (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> N
:: (1/1) Parsing SRCINFO: cider-minimal
resolving dependencies...
looking for conflicting packages...

Package (4)            New Version  Net Change

community/node-gyp     9.0.0-1        4.31 MiB
community/nodejs-nopt  5.0.0-2        0.03 MiB
community/npm          8.5.5-1        6.05 MiB
community/semver       7.3.7-1        0.11 MiB

Total Installed Size:  10.50 MiB

:: Proceed with installation? [Y/n] Y
(4/4) checking keys in keyring                                                                       [------------------------------------------------------------] 100%
(4/4) checking package integrity                                                                     [------------------------------------------------------------] 100%
(4/4) loading package files                                                                          [------------------------------------------------------------] 100%
(4/4) checking for file conflicts                                                                    [------------------------------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 85
:: Processing package changes...
(1/4) installing nodejs-nopt                                                                         [------------------------------------------------------------] 100%
(2/4) installing semver                                                                              [------------------------------------------------------------] 100%
(3/4) installing node-gyp                                                                            [------------------------------------------------------------] 100%
(4/4) installing npm                                                                                 [------------------------------------------------------------] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Performing snapper post snapshots for the following configurations...
==> root: 86
==> Making package: cider-minimal 1.1.0.2120.ad86f58-1 (Saturday 14 May 2022 07:08:11 PM)
==> Retrieving sources...
  -> Cloning Cider git repo...
Cloning into bare repository '/home/kundan/.cache/yay/cider-minimal/Cider'...
remote: Enumerating objects: 15357, done.
remote: Total 15357 (delta 0), reused 0 (delta 0), pack-reused 15357
Receiving objects: 100% (15357/15357), 16.37 MiB | 8.39 MiB/s, done.
Resolving deltas: 100% (10147/10147), done.
  -> Found Cider.desktop
==> Validating source files with sha256sums...
    Cider ... Skipped
    Cider.desktop ... Passed
 -> npm not satisfied, flushing install queue
==> Making package: cider-minimal 1.1.0.2120.ad86f58-1 (Saturday 14 May 2022 07:08:17 PM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating Cider git repo...
Fetching origin
  -> Found Cider.desktop
==> Validating source files with sha256sums...
    Cider ... Skipped
    Cider.desktop ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of Cider git repo...
Cloning into 'Cider'...
done.
Switched to a new branch 'makepkg'
==> Starting pkgver()...
==> Updated version: cider-minimal 1.2.1.2372.b515d49-1
==> Sources are ready.
==> Making package: cider-minimal 1.2.1.2372.b515d49-1 (Saturday 14 May 2022 07:08:23 PM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...
Building Cider on v1.2.1.2372.b515d49 : [Install Build Dependencies] | Build | Done
yarn install v1.22.18
info No lockfile found.
[1/4] Resolving packages...
warning electron-builder > dmg-builder > dmg-license@1.0.11: Disk image license agreements are deprecated by Apple and will probably be removed in a future macOS release. Discussion at: https://github.com/argv-minus-one/dmg-license/issues/11
warning electron-webpack > webpack-dev-server > chokidar@2.1.8: Chokidar 2 does not receive security updates since 2019. Upgrade to chokidar 3 with 15x fewer dependencies
warning electron-webpack > webpack-dev-server > chokidar > fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
warning electron-webpack > webpack-dev-server > url > querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
warning electron-webpack > webpack-dev-server > webpack-log > uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
warning electron-webpack > webpack-cli > findup-sync > micromatch > snapdragon > source-map-resolve@0.5.3: See https://github.com/lydell/source-map-resolve#deprecated
warning electron-webpack > webpack-cli > findup-sync > micromatch > snapdragon > source-map-resolve > resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
warning electron-webpack > webpack-cli > findup-sync > micromatch > snapdragon > source-map-resolve > source-map-url@0.4.1: See https://github.com/lydell/source-map-url#deprecated
warning electron-webpack > webpack-cli > findup-sync > micromatch > snapdragon > source-map-resolve > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
[2/4] Fetching packages...
error @playwright/test@1.22.0: The engine "node" is incompatible with this module. Expected version ">=14". Got "12.22.12"
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
==> ERROR: A failure occurred in build().
    Aborting...
checking dependencies...
:: nodejs-lts-erbium optionally requires npm: nodejs package manager

Package (4)  Old Version  Net Change

node-gyp     9.0.0-1       -4.31 MiB
nodejs-nopt  5.0.0-2       -0.03 MiB
npm          8.5.5-1       -6.05 MiB
semver       7.3.7-1       -0.11 MiB

Total Removed Size:  10.50 MiB

:: Do you want to remove these packages? [Y/n] 
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 87
:: Processing package changes...
(1/4) removing npm                                                                                   [------------------------------------------------------------] 100%
(2/4) removing node-gyp                                                                              [------------------------------------------------------------] 100%
(3/4) removing semver                                                                                [------------------------------------------------------------] 100%
(4/4) removing nodejs-nopt                                                                           [------------------------------------------------------------] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Performing snapper post snapshots for the following configurations...
==> root: 88
 -> error making: cider-minimal

I would start doing some investigation about this.

https://yarnpkg.com/en/docs/cli/install

https://archlinux.org/packages/community/x86_64/nodejs/

1 Like

1 - You might want to try the regular cider package instead of cider-minimal, as it has been more recently updated.

2 - This is a pinned comment from the cider-git package page (the comment is from the mainatiner of the package); it might apply to the cider-minimal package as well:

Core_UK commented on 2022-02-01 02:29 (UTC))

Running this on Node.js 17 or later will fail. This is due to Node.js 17 no longer writing openssl_fips to config.gypi so it’s not there in Node.js 17’s process.config. It is suggested to downgrade to nodejs-lts-gallium to resolve this issue.

2 Likes

Done the normal Cider works. Thanks all of you for helping out and sorry for the trouble.

3 Likes

I know when I run updates since I installed cider yay tells me:

cider: local (1.4.6.2337-1) is newer than AUR (1.4.5-1)

So just be aware of that. I am not sure why the version is different than what the AUR says, but just thought I would point it out that I get that message all the time.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.