Error when updating

when i tried to update this morning got a error same the one in this post Is this error a big deal?
I then updated my endeavouros mirrors using the button on the welcome app and then got this:

[cc@computer ~]$ sudo pacman -Syyu
[sudo] password for cc: 
error: GPGME error: No data
:: Synchronizing package databases...
 endeavouros                                                             25.1 KiB  9.87 KiB/s 00:03 [----------------------------------------------------------] 100%
 core                                                                   130.4 KiB  74.6 KiB/s 00:02 [----------------------------------------------------------] 100%
 extra                                                                    8.3 MiB  2.51 MiB/s 00:03 [----------------------------------------------------------] 100%
 multilib                                                               143.2 KiB  82.0 KiB/s 00:02 [----------------------------------------------------------] 100%
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

Try the solution suggested in ArchWiki:

Hopefully it will resolve the issue.

1 Like

sudo rm -r /var/lib/pacman/sync

After that, sudo pacman -Syyu

1 Like

thank you @anthony93 @pebcak. That worked

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.