Error When trying to execute aafire or BB or similar ASCII console goodies

ok,
not a total noob, but pretty close, and I wasn’t sure where else this might go
I was looking at a few articles, and found some fun old console goodies to play with, cmatrix, xcowsay etc.

There’s a couple however that spit out errors when I try, most notable aafire.
Attempting to run aafire (or bb or a couple others) results with this error

[james@Kalevala-Linux ~]$ aafire
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  45 (X_OpenFont)
  Serial number of failed request:  7
  Current serial number in output stream:  8
[james@Kalevala-Linux ~]$ 

I tried some basic google-fu, and from what I can tell it seems to be some sort of font issue, but I could not find a solution, a lot of info I found was VERY outdated (think 2002 on average).

I know it’s silly
I know it’s useless.
But I would love to get this working.

Thanks in advance for any and all help

Do you xorg-fonts installed? Think that may be the problem, works here.

Tried looking, looks like some are installed, but to be sure I tried reinstalling, ran into a different problem:

[james@Kalevala-Linux ~]$ sudo pacman -S xorg-fonts-100dpi
warning: xorg-fonts-100dpi-1.0.3-7 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) xorg-fonts-100dpi-1.0.3-7

Total Download Size:   11.89 MiB
Total Installed Size:  12.18 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 xorg-fonts-100dpi-1.0.3-7-any             11.9 MiB  15.2 MiB/s 00:01 [---------------------------------------] 100%
(1/1) checking keys in keyring                                        [---------------------------------------] 100%
(1/1) checking package integrity                                      [---------------------------------------] 100%
(1/1) loading package files                                           [---------------------------------------] 100%
(1/1) checking for file conflicts                                     [---------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
E: ts: Failed to get partition list.
E: System disk not found!
Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.
[james@Kalevala-Linux ~]$

Can’t install because timeshift is running?
trying to load timeshift, says it’s in live USB mode, and to select a BTRFS root volume, and now I’m all confused and very worried

Timeshift is borked run:

yay timeshift

first, to reinstall and fix timeshift from aur. But looks like fonts are not the problem:

warning: xorg-fonts-100dpi-1.0.3-7 is up to date -- reinstalling

ok trying to fix timeshift runs into the same problem of not being able to install/upgrade because timeshift is running,
only reason I have time shift is I followed the tutorial on here for BTRFS with LUX the whole copy & paste thing.

[james@Kalevala-Linux ~]$ yay timeshift
4 aur/autoupgrade 1.0.0-1 (+1 0.00) 
    Automatic snapshot and then upgrade the system. (When the system fails, run `sudo timeshift --restore` and remove this package until the problem is solved.)
3 aur/timeshift-bin 20.11.1-1 (+8 3.59) 
    A backup and restore utility
2 aur/timeshift-autosnap 0.9-1 (+20 2.27) (Installed)
    Timeshift auto-snapshot script which runs before package upgrade using Pacman hook.
1 aur/timeshift 20.11.1+3+g08d0e59-4 (+181 12.32) (Installed: 20.11.1+3+g08d0e59-3)
    A system restore utility for Linux
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==>

it’s starting to look like I might not be able to install/update anything until I get this fixed

Reboot and try again to update timeshift. That should knock out the process.

I already did a reboot, after the first response

ps aux | grep -i timeshift

Returns?

here you go:

[james@Kalevala-Linux ~]$ ps aux | grep -i timeshift
james      55006  0.0  0.0   6404  2404 pts/2    S+   15:18   0:00 grep -i timeshift
[james@Kalevala-Linux ~]$ ^C

So timeshift is not running. Remove timeshift-autosnap, then rebuild timeshift, then reinstall timeshift-autosnap.

First off, thank you SO SO much for all the help
uninstalled as directed,
then did yay -S timeshift
when it asked if I wanted to clean build files, I told it yes.
That seemed to work fine
did the same with autosnap, again telling tit to clean build, and again this seems to have worked just fine!

Now back to the original problem :smiley: BRB going for a smoke.

Ok, again thank you SO much!!!

aafire works for me on gnome:


Try the fonts install again.

Ok, to be clear, which package(s) do I need to isntall ?
xorg-fonts-75dpi-otb xorg-fonts-100dpi-otb

 1 extra/xorg-font-util 1.3.2-2 [xorg-fonts xorg] [installed]
 7 extra/xorg-fonts-alias-misc 1.0.4-1 [installed]
 9 extra/xorg-fonts-encodings 1.0.5-2 [xorg-fonts xorg] [installed]
10 extra/xorg-fonts-misc 1.0.3-10 [installed]

is what I have.

What is BB?

Ok made sure all of the above were (re)installed:
getting the same error as before

[james@Kalevala-Linux ~]$ aafire
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  45 (X_OpenFont)
  Serial number of failed request:  7
  Current serial number in output stream:  8
[james@Kalevala-Linux ~]$ 


3rd one down BB it’s another little Ascii fun thing.

Obviously, if this doesn’t work, it doesn’t exactly ruin my life. but I am curious as to what’;s going on

Try the 75dpi and 100dpi fonts, install and reboot.

Nope can’t install bb as it clashes with something else I use:

 bb
Babashka v0.4.4 REPL.
Use :repl/quit or :repl/exit to quit the REPL.
Clojure rocks, Bash reaches.

user=>
1 Like

THERE WE GO!!!
got it
working great now, thank you so so much

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.