Error When Restoring Timeshift Backup


I am attempting to restore a timeshift backup of my system. I am using rsync mode and have the data backed up to an external drive. My EOS install is using the basic encrypted btrfs config. I am able to select the restore option and it provides me with a recommended target device, however when I select next it gives me an error.

I am unsure how to proceed from here, and am hesitant to just start trying things and putting my data at risk.

Here is the error and config

You probably have to decrypt your luks partition first with cryptsetup open

That will create a new device which is the unencrypted version of the partition.

Okay, I tried running that command
sudo cryptsetup open --type luks /dev/nvme1n1p2 main_crypt
and got an error that says Cannot use device which is already in use (already mapped or mounted)
I did already use the live iso file manager to open/unlock the partition, which I believe is why it is saying that. I tried timeshift again and it still gives me the same error

Did you point it to the decrypted device?

In other words, select the device from /dev/mapper/*

I’m not sure. And if I did not, I am not sure how I would. When I launch timeshift it asks me to select the drive that has my backups. After I click “restore” it sends me to the screen in the first image I posted. I can open up the options to select other places to restore the parts of the backup, but I have no idea which one (if any) is the right one.

The options

This would be the spot I think. You need to selected correct device here if possible. Does the decrypted device show up here?

If not, then I am out of ideas. Might have to ask the timeshift folks unless someone else on this forum pops in who can answer.

Yes, but selecting it there gives me a There are no snapshots on this device error, as my backups are on a different drive.

To expand on that further, the SSD in that image (nvme1n1) is the decrypted device which has the EOS system I am trying to restore. I think the issue I have is that the /boot path of the backup is not “mapped” to a place on the drive, like the other ones as seen here:

The menu I posted:

lets me pick the partition of the device to map to /boot but I don’t know if that will fix the issue, or which partition I should select.

Alright, I might look into that. Thanks!

1 Like

I may have found a work around to this issue, although the GUI is still not usable. This post suggests that it is some sort of bug with timeshift. It pointed to this as a possible fix, basically suggesting to completely bypass the GUI and run sudo timeshift --restore from the command line and accept all the defaults.

I did so and the command ran, however now my system only boots into emergency mood so this may not be a viable fix for restoring backups.