Error used ventoy install


I am trying to install using ventoy which I sort of have to for my Intel NUC device and I run into the error below. Ventoy does ask me if I want to use ‘normal mode’ or ‘grub mode’ when starting up the ISO and I always choose normal since it’s worked in the past. Any ideas?

Yes, choose the Grub mode.
That is the option that has been working for me.

I just tried that as well and its not working It showed me the same error as the screenshot. I’m stuck right now. I cant reinstall EOS.

Do you have another Linux ISO on your Ventoy USB?

If you have and also if you have another usb flashdrive, boot that up and write EnOS to the other usb.

I cant do that because ventoy is the only way I can install EndeavourOS. The reason is because my system cannot read USB images using MBR rather than GPT. Ventoy is the only way I can use EOS with GPT. What other choice do I really have? The last time I did this it installed no problem. Now suddenly this is a problem and I dont know why.

Ventoy is just not a reliable way to have bootable ISO images. When it works, it’s wonderful, but often it does not work.

Sorry, that makes no sense to me at all.

Just write an ISO image with dd or Popsicle to a USB drive.

NVM I managed to make it work using the emergency mode (forgot the name). Something about nomodeset. Well, I guess that wraps that up.

So Ventoy seems not to have been at fault here but you needed a specific kernel boot parameter, nomodeset, for the ISO to boot on your hardware?

Ventoy seems to be another one of those pieces of software in the “Linux World” that people have different experience and opinions about.

For me it has always worked. I’ve got a Ventoy flashdrive with several Linux ISOs, Windows, Hirens’ BootCD, Rescuezilla and some other rescue tools. It has served me more than once for installing, troubleshooting and rescuing my systems.

Ventoy usually works for me, but there are a few distros (and no I don’t remember) that never work under it, though they work perfectly written directly to the flash drive in grub mode.
Yes, different strokes perhaps :slight_smile: