Error Updating EndeavourOS: Unknown Trust Signature

Hi there,

I apologize for this silly question, but I’ve been unable to update my EndeavourOS computer since May 20 due to the following error:

When I attempt to update the system using sudo yay or sudo pacman -Syu, I encounter the following error message:

error: endeavouros-mirrorlist: signature from “manuel <>” is unknown trust
:: The file /var/cache/pacman/pkg/endeavouros-mirrorlist-23.6-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to remove it? [Y/n]

Here’s what I have tried to resolve the issue:

  1. pressed y → unable to proceed with the update
  2. pressed n → unable to proceed with the update
  3. looked for help online (forums / docs) → haven’t found any working solution
  4. read this thread on the forum: I cant update system

The output of sudo pacman -Sy archlinux-keyring is “correct,” indicating that I don’t receive any errors and that archlinux-keyring-20230504-1 gets reinstalled even if it was already updated.

Lastly, here are the details of my system from neofetch :
OS: EndeavourOS Linux x86_64
Kernel: 6.3.2-arch1-1
Shell: bash 5.1.16
DE: Plasma 5.27.5

Has anyone experienced this problem before? Do you have any advice on how to solve it?

Thank you in advance,

P.S.: Please forgive my poor English!

A GUI app for selecting Arch mirrors


Have you tried to update your mirrors after installing the keyring? There are tools for this in the welcome app

1 Like

Hi @smokey and @Pinhead, thank you both for your helpful responses!

Before updating my system, I always make sure to update both Arch and EndeavourOs Mirrors using the welcome app (as indicated in the link shared by @Pinhead).

Regarding the Arch mirrors, I currently have the default settings configured as follows:

  • Italy is selected (since I live in Italy)
  • The option for including https mirrors is checked

I have left all other options unchecked.

Do you think I should make any adjustments to these settings?

Try installing endeavouros-keyring first:

sudo pacman -Sy endeavouros-keyring

Update the system:

sudo pacman -Syu


Hi @pebcak, thank you for your kind reply!

You are a genius! I had archlinux-keyring installed but was completely unaware of the existence of endeavouros-keyring. Installing it immediately solved the problem!

Thank you so much to everyone!

(P.S.: This forum is amazing!)

1 Like

I was unaware of this also, I’m adding it to my notes now just incase ever needed it


In fairness, the EndeavourOS updater should do this by itself. Can anyone do a PR, or is it up to me…?

1 Like

There is a command, eos-update that does do this. However, EndeavourOS doesn’t use a custom updater anymore. It was decided to simply use yay instead so I am not sure what you would PR.

I am also not sure having the updater prioritize keyring updates is actually the right thing to do anyway.


I know UpdateInTerminal is deprecated. eos-udpate also deprecated?

Users could use checkupdates from pacman-contrib and look for *-keyring packages in the list. And if there are keyrings ready, install those first. Otherwise, update as they usually do.

One thing is, AUR helpers like yay and paru are not supported by Arch Linux.

1 Like

As far as I know it is not deprecated. The issue is that EndeavourOS is not the kind of distro that defines a single way to update your system. This means that everyone does it differently and uses different tools.

We have no predictable way to get in the middle of updates.

Neither is EndeavourOS. :wink:


eos-update is not deprecated. :sweat_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.