Error tonight in the update (libblockdev - libblockdev-utils)

Good evening
Tonight I launched the update (sudo pacman -Syu) and he gave me back this error:

:: libbuckdev and libbu-Utils go into conflict

And it stops everything without being proceeding with the update.
Does anyone know how to solve this problem ???

1 Like

Same issue here. Anyone found a resolution?

Replace libblockdev-utils with extra/libblockdev? [Y/n] y

Say y(es) to replace!

1 Like

I tried both by responding Y (yes) and responding N (not) … always gives me back the same error



sudo pacman -Rdd libblockdev-utils && sudo pacman -Syu libblockdev


I solved the problem by updating the mirror
(I removed 2 nations close to me and I only gave them up in my nation)

I am in Italy: I always updated the Mirror with “Italy” “France” and “Switzerland”
I left Italy alone by removing the others and now he does not even ask me to replace the two DependeNces anymore. Probably something does not work in France or Switzerland!


tried updating mirrors, but error continued
tried pebcak’s solution and it resolved problem


I didn’t trust my instincts so searched forum first. I hit Y–after reading you-- and rest of update threw no errors.
Did your -Rdd command just for the redundant certainty but of course pacman didn’t see package since I nuked it with my Y.

thanks for being there of the OP. Helped me as well.

1 Like

Doing this you had already resolved the conflict.

The pacman -Rdd command was meant to be run if the conflict would still remain unresolved.

this is the current (probably the actual right) working solution , thanks

1 Like