Error mounting shared NTFS disk partition in dual-boot system

I ran into this issue once before, and it somehow resolved itself after some time. But now that it has appeared again, I would like to know why this is happening and how I can solve this issue.

The issue is that I get an error when I try to mount a shared NTFS disk partition that is shared across my Linux and Windows systems, which I have set up following a guide such as this one. I have done so to easily access the same files across my EndeavourOS and Windows systems.

It usually works great, but every once in a while, it somehow breaks, and I am unable to mount the shared partition through Dolphin, resulting in the following error after I input my password to mount:

An error occurred while accessing ‘shared’, the system responded: The requested operation has failed: Error mounting /dev/nvme0n1p4 at /run/media/jlee/shared: wrong fs type, bad option, bad superblock on /dev/nvme0n1p4, missing codepage or helper program, or other error

I found that when this happens, it’s always after I’ve booted into Windows and re-booted into Linux. It doesn’t always happen, but when it does, it’s always after I’ve been on my Windows system, so I assume it’s something Windows-related. An important point is that I get this error on Endeavour, but I can access the files with zero issues from Windows.

I tried rebooting multiple times, booting into Windows then re-booting into Endeavour, but nothing really worked.

This post on the Arch forum is exactly the issue I’m facing, but the poster solved it by formatting the disk on Windows. I suppose I can also do this after making a backup in Windows since I can thankfully still access the partition from Windows, but I’d like to understand why this is happening before taking that approach.

Some more relevant information below:

Output of lsblk -f

❯ lsblk -f
NAME        FSTYPE FSVER LABEL  UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
└─sda1      exfat  1.0   JBL_SD 7243-6E7C                                           
├─nvme0n1p1 vfat   FAT32        028D-6D1A                                           
├─nvme0n1p3 ntfs                8C0C8E0E0C8DF40C                                    
├─nvme0n1p4 ntfs         shared 1E7259C77259A475                                    
├─nvme0n1p5 ntfs                2C4C1B424C1B066C                                    
├─nvme0n1p6 vfat   FAT32        FF23-EA87                             510.7M     0% /boot/efi
├─nvme0n1p7 swap   1            56dd6df7-92c8-404a-a80c-45166d4cddd1                [SWAP]
├─nvme0n1p8 ext4   1.0          53a72ff9-ca2c-479f-bc8a-2e3836a2ce3b    8.5G    68% /
└─nvme0n1p9 ext4   1.0          0840d625-d1d0-43ba-8240-ea51eeb0bb54  138.9G    29% /home

Contents of /etc/fstab

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=FF23-EA87                            /boot/efi      vfat    fmask=0137,dmask=0027 0 2
UUID=56dd6df7-92c8-404a-a80c-45166d4cddd1 swap           swap    defaults   0 0
UUID=53a72ff9-ca2c-479f-bc8a-2e3836a2ce3b /              ext4    noatime    0 1
UUID=0840d625-d1d0-43ba-8240-ea51eeb0bb54 /home          ext4    noatime    0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

ntfs-3g installed:

❯ pacman -Q | grep ntfs
ntfs-3g 2022.10.3-1

Output of mount

❯ mount -t ntfs3 /dev/nvme0n1p4
mount: /dev/nvme0n1p4: can't find in /etc/fstab.

Attempt to run ntfsfix

❯ sudo ntfsfix /dev/nvme0n1p4
[sudo] password for jlee: 
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/nvme0n1p4 was processed successfully.

Although ntfsfix was successful, I am still unable to access the partition through Dolphin.

From the above, it seems the crux of the issue is that the partition in question, /dev/dvme0n1p4, is not listed in /etc/fstab, and that I need to add the entry to /etc/fstab.

What is the best way to go about fixing this issue?

Have you disabled “fast startup” in Windows? Having that enabled will cause this behavior

1 Like

Thanks for the input. Yes, fast startup has been disabled in Windows:

Now that I’ve already booted into Windows, I also checked to see if there was anything I could do from the Windows side, and noticed this menu:

Running the Error checking menu actually told me there was an error that needs to be fixed, and going into the event log, I found this:

Stage 3: Examining security descriptors ...
Security descriptor verification completed.
 Phase duration (Security descriptor verification): 2.90 milliseconds.
  1366 data files processed.                                             Phase duration (Data attribute verification): 3.92 milliseconds.
Windows has found problems that must be fixed offline.
Please run "chkdsk /f" to fix the issues.

I ran the Error checking menu again, and then this time, it said there were no errors. I’m not sure what happened, but I’ll try rebooting into Endeavour now and see if anything changed.

Huh, what do you know, running the Error checking function under the Tools tab of the properties menu from Windows seems to have fixed the issue.

I can now mount and access the shared disk partition using Dolphin:

Still not sure what the cause of the issue is (maybe it’s just Windows being Windows), but I’m glad I now have some sort of fix for this issue should it arise again in the future.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.