ERROR: Missing 5.15.23-2-lts kernel modules tree

SOLUTION
So i got help from someone on discord it turns out that i had linux-lts-headers installed but not linux-lts which made it get confused alot which caused this entire problem
if someone makes the same mistake just download linux-lts and it should reattempt the driver installation by itself

i keep getting this error when trying to get nividia drivers on my device (supported gpu btw) ==> ERROR: Missing 5.15.23-2-lts kernel modules tree for module nvidia/510.47.03.

this is the fix i found on arch wiki # dkms autoinstall
i dont know how to start konsole with # so i jut wrote dkms autoinstall and nothing happened
i also tried sudo pacman -Syu linux-latest-headers but i got target not found
aswell as -Syu nvidia but when i tried installing the driver again i got the same problem

1 Like

Probably something to do with …

There will be some instability whilst packages are rebuilt against the updated toolchain.

2 Likes

The # is used to denote a root login. $ is a normal user login. You can achieve the same effect by using sudo, so

sudo dkms autoinstall

That sounds like a Manjaro package.

4 Likes

Well, it’s not in the Arch repos OR the AUR; I just searched for it so that can only mean one thing… :male_detective:

2 Likes

I’m pretty sure that linux-latest and linux-latest-headers were Manjaro packages; I don’t think they use them anymore, though.

2 Likes

Post the result of inxi -Fxxxza --no-host after you enter it into the terminal. Paste the output here with three ``` above and below the output.

Also return sudo parted -l<—that is the letter l not a number 1.

@studentoncrack post the output. If you are using manjaro you should say so. Primarily you should be asking on their forums if this is the case.

4 Likes

It certainly was back in 2020.

5 Likes

Manjaro packages but they were dropped long time ago. OP isn’t telling something important here.

2 Likes

it’s now that i know that they are old packages that where dropped i am still new to linux so forgive me for mistakes, that being said it worked just fine after a fix that i mentioned in the updated post

1 Like

Are you on manjaro or eos? or arch :thinking:

1 Like

I edited your OP this is certainly not solved. Post the requested output please. I won’t ask a third time.

i did attach a proof of it working but here is the output

ystem:
  Kernel: 5.16.9-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=3222e6da-6881-44fa-ad19-c1f605f8d22d rw quiet loglevel=3
    nowatchdog nvme_load=YES
  Desktop: KDE Plasma 5.24.1 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: Hewlett-Packard product: HP 15 Notebook PC
    v: 0990110000000000000600087 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 2212 v: 86.56 serial: <superuser required>
    UEFI: Insyde v: F.45 date: 06/27/2018
Battery:
  ID-1: BAT1 charge: 1.3 Wh (100.0%) condition: 1.3/1.3 Wh (100.0%)
    volts: 16.9 min: 14.8 model: 11-85 OA04041 type: Li-ion serial: <filter>
    status: Full
CPU:
  Info: model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell
    family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1693 high: 1696 min/max: 800/2700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1696 2: 1693 3: 1690
    4: 1696 bogomips: 19162
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
  620M/625M/630M/720M]
    vendor: Hewlett-Packard driver: N/A alternate: nouveau, nvidia_drm, nvidia
    bus-ID: 09:00.0 chip-ID: 10de:1140 class-ID: 0302
  Device-3: Suyin HP Truevision HD type: USB driver: uvcvideo
    bus-ID: 1-1.5:4 chip-ID: 064e:9302 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: modesetting display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101
    size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2)
    v: 4.5 Mesa 21.3.6 compat-v: 3.0 direct render: Yes
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c
    class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.16.9-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 5000 bus-ID: 08:00.0
    chip-ID: 10ec:8136 class-ID: 0200
  IF: enp8s0 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 3000
    bus-ID: 0a:00.0 chip-ID: 10ec:b723 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-1.4:3 chip-ID: 0bda:b001 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
Drives:
  Local Storage: total: 689.33 GiB used: 482.86 GiB (70.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 model: SSD25-240GB size: 223.57 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 1A0 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: USB3.0 high speed
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 2210 scheme: GPT
Partition:
  ID-1: / raw-size: 92.94 GiB size: 90.92 GiB (97.83%) used: 55.9 GiB (61.5%)
    fs: ext4 dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.3 MiB (26.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 61.0 C mobo: 61.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 191 Uptime: 22m wakeups: 1 Memory: 11.62 GiB
  used: 3.28 GiB (28.2%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: 1238 pacman: 1227 lib: 420 flatpak: 0 snap: 11
  Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12

One more please.

i have windows installed on the 240gb ssd as well which explains why it has a non linux file types

[studentoncrack@studentoncrack-hp15notebookpc ~]$ sudo parted -l
Model: ATA SSD25-240GB (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp
2 106MB 123MB 16,8MB Microsoft reserved partition msftres
3 123MB 140GB 140GB ntfs Basic data partition msftdata
5 140GB 240GB 99,8GB ext4 root
4 240GB 240GB 533MB ntfs hidden, diag

Model: USB3.0 high speed (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 135MB 134MB msftres
2 135MB 500GB 500GB ntfs Basic data partition msftdata

[studentoncrack@studentoncrack-hp15notebookpc ~]$