Error installing repo messages

Trying to upgrade today and got this message at the end:

I updated Arch and Endeavour mirrors, restarted, tried again, but still got the same message.
Here is my boot log: https://0x0.st/-k.txt

Please advise.

While I won’t be promising that you should in this specific case, you can do

sudo pacman -Syu --overwrite '*'

It’s probably fine; the issue being a former partial update…

1 Like

cd into /usr/lib/python3.10/site-packages/cairo/__pycache__/ and rename the __init__.cpython-310.pyc file to something else. After that, run the update again.

This is the practice recommended by the Arch Wiki. Using the --overwite flag is not recommended because you run the risk of losing important files you might need.

https://wiki.archlinux.org/title/pacman#"Failed_to_commit_transaction_(conflicting_files)"_error

This article contains pretty much everything you need to know on handling basic pacman error messages.

1 Like

Just before you came on I implemented @rene 's recommendation, and that worked.
However, your warning got me worried. Should I still do what you recommend, and run the update again, or is there no point now?

In this case, using the --overwrite flag is harmless. The file in question is just a file containing bytecode that python will generate again once the appropriate scripts are run.

Just be more careful with the --overwrite flag in general and read through the Arch Wiki page I sent you. Cheers.

1 Like

Thanks for your advice.

Thank you. For anyone else who reads this in the future, be careful with the --overwrite command, as anthony93 points out above

No problem.

1 Like

Put this here as well for “posterity”:

1 Like

So my advise would then have been the “I don’t care” way :slight_smile:

1 Like

In my notes, it’s called “What the Heck” way :sweat_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.