Error installing kweather from the AUR

I am trying to install kweather from the AUR. However, it fails with the following error message.

$ yay -S kweather
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:1]  kweather-22.09-1

:: (1/1) Downloaded PKGBUILD: kweather
  1 kweather                         (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: (1/1) Parsing SRCINFO: kweather
  1 kweather                         (Build Files Exist)
==> PKGBUILDs to edit?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
==> Making package: kweather 22.09-1 (Monday 07 November 2022 07:46:21 PM)
==> Retrieving sources...
  -> Downloading kweather-22.09.tar.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:03 --:--:--     0
100  991k  100  991k    0     0   228k      0  0:00:04  0:00:04 --:--:--  228k
==> Validating source files with sha256sums...
    kweather-22.09.tar.xz ... Passed
==> Making package: kweather 22.09-1 (Monday 07 November 2022 07:46:30 PM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found kweather-22.09.tar.xz
==> Validating source files with sha256sums...
    kweather-22.09.tar.xz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting kweather-22.09.tar.xz with bsdtar
==> Sources are ready.
==> Making package: kweather 22.09-1 (Monday 07 November 2022 07:46:41 PM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting build()...
-- The C compiler identification is GNU 12.2.0
-- The CXX compiler identification is GNU 12.2.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found Python3: /usr/bin/python3.10 (found version "3.10.8") found components: Interpreter 
-- Could NOT find ReuseTool (missing: REUSETOOL_EXECUTABLE) 
CMake Warning at /usr/share/ECM/modules/ECMCheckOutboundLicense.cmake:86 (message):
  Reuse tool not found, skipping test generation
Call Stack (most recent call first):
  CMakeLists.txt:30 (include)


-- Skipping execution of outbound license tests.
-- Installing in the same prefix as Qt, adopting their path scheme.
-- Looking for __GLIBC__
-- Looking for __GLIBC__ - found
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_DATE_TIME
-- Performing Test HAVE_DATE_TIME - Success
-- Found KF5Config: /usr/lib64/cmake/KF5Config/KF5ConfigConfig.cmake (found version "5.99.0") 
-- Found KF5Kirigami2: /usr/lib64/cmake/KF5Kirigami2/KF5Kirigami2Config.cmake (found version "5.99.0") 
-- Found Gettext: /usr/bin/msgmerge (found version "0.21.1") 
-- Found KF5I18n: /usr/lib64/cmake/KF5I18n/KF5I18nConfig.cmake (found version "5.99.0") 
-- Found KF5CoreAddons: /usr/lib64/cmake/KF5CoreAddons/KF5CoreAddonsConfig.cmake (found version "5.99.0") 
-- Found KF5Notifications: /usr/lib64/cmake/KF5Notifications/KF5NotificationsConfig.cmake (found version "5.99.0") 
-- Found KF5: success (found suitable version "5.99.0", minimum required is "5.90.0") found components: Config Kirigami2 I18n CoreAddons Notifications 
CMake Error at CMakeLists.txt:63 (find_package):
  Could not find a configuration file for package "KF5KWeatherCore" that is
  compatible with requested version "0.6.0".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/KF5KWeatherCore/KF5KWeatherCoreConfig.cmake, version: 0.5.0
    /usr/lib/cmake/KF5KWeatherCore/KF5KWeatherCoreConfig.cmake, version: 0.5.0
    /lib64/cmake/KF5KWeatherCore/KF5KWeatherCoreConfig.cmake, version: 0.5.0
    /lib/cmake/KF5KWeatherCore/KF5KWeatherCoreConfig.cmake, version: 0.5.0



-- Configuring incomplete, errors occurred!
See also "/home/archisman/.cache/yay/kweather/src/build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: kweather

How to fix this?

Read the comments. Someone already reported its failing to build
https://aur.archlinux.org/packages/kweather#comment-888550

@sradjoker It was me who reported it :man_facepalming:.
I asked it here in case someone knows about any workarounds.

I figured out the issue, its not with this package but the package kweathercore.

The AUR package for that package is wrongly done.
Try building kweathercore using this PKGBUILD and then installing it. After that trying building kweather

I flagged the kweathercore out of date. There is already a comment about this but the maintainer hasn’t responded yet.
https://aur.archlinux.org/packages/kweathercore#comment-884370

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.