Error installing Flatpak on EndeavourOS KDE

Hi all friends.

I’m new to Linux and I still have a lot to learn. I’m trying to install Flatpak on my EndeavourOS KDE, but I’m getting this error.

I’m sorry if this is a dumb question, but my English is very bad and I don’t always understand terminal errors.

Thank you in advance for your help.

[septem@septem ~]$ yay -S flatpak
Sync Explicit (1): flatpak-1:1.15.4-1
[sudo] password for septem: 
resolving dependencies...
looking for conflicting packages...

Package (5)               New Version  Net Change  Download Size

extra/geoclue             2.7.0-1        1,55 MiB       0,23 MiB
extra/libmalcontent       0.11.1-2       0,20 MiB       0,04 MiB
extra/ostree              2023.6-3       4,36 MiB       0,79 MiB
extra/xdg-desktop-portal  1.16.0-3       1,96 MiB       0,36 MiB
extra/flatpak             1:1.15.4-1     6,89 MiB       1,76 MiB

Total Download Size:    3,18 MiB
Total Installed Size:  14,96 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 libmalcontent-0.11.1-2-x86_64          39,8 KiB  97,0 KiB/s 00:00 [------------------------------------] 100%
 xdg-desktop-portal-1.16.0-3-x86_64    367,3 KiB   829 KiB/s 00:00 [------------------------------------] 100%
 ostree-2023.6-3-x86_64                808,1 KiB  1694 KiB/s 00:00 [------------------------------------] 100%
 geoclue-2.7.0-1-x86_64.pkg.tar.zst failed to download
 flatpak-1:1.15.4-1-x86_64            1801,0 KiB  2,88 MiB/s 00:01 [------------------------------------] 100%
 Total (5/5)                             3,2 MiB   304 KiB/s 00:11 [------------------------------------] 100%
error: failed retrieving file 'flatpak-1:1.15.4-1-x86_64.pkg.tar.zst' from : Failed to connect to port 443 after 10001 ms: Timeout was reached
error: failed retrieving file 'ostree-2023.6-3-x86_64.pkg.tar.zst' from : Failed to connect to port 443 after 10000 ms: Timeout was reached
error: failed retrieving file 'xdg-desktop-portal-1.16.0-3-x86_64.pkg.tar.zst' from : Failed to connect to port 443 after 10000 ms: Timeout was reached
warning: too many errors from, skipping for the remainder of this transaction
error: failed retrieving file 'geoclue-2.7.0-1-x86_64.pkg.tar.zst' from : Connection timeout after 10000 ms
error: failed retrieving file 'libmalcontent-0.11.1-2-x86_64.pkg.tar.zst' from : Connection timeout after 10000 ms
error: failed retrieving file 'geoclue-2.7.0-1-x86_64.pkg.tar.zst' from : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
 -> error installing repo packages
[septem@septem ~]$ 

I ran a yay -Ss flatpak and found these packages, so I installed the last one, as one of our friends on the forum told me:

Update the mirrors

sudo reflector --protocol https --verbose --latest 25 --sort rate --save /etc/pacman.d/mirrorlist && sudo eos-rankmirrors --verbose && yay -Syyu
1 Like

Have you updated your system before?

1 Like

Yesterday I updated these 2 mirrors from this Welcome panel (the first 2 buttons, since I don’t know how to do it any other way).

Both updated successfully, and then I did a yay. Anyway this afternoon I will do it again, maybe I didn’t do it correctly. I’ll try it again later and post the results.

If the problem isn’t expired mirrors, it means you’ve had a temporary problem with your internet connection.

1 Like

With the exception of one, all mirrors from your first comment were not reachable and the one that was reachable took a long time to load. you should update your mirror list.

1 Like

You are right, the problem occurred after updating the mirrors.

I update them through the Welcome graphical interface, my country appears checked, and then I check the Worldwide mirror and nothing more, I click OK and I get this message (I never got this error, and I update my mirrors every 3 weeks I think):

Afterwards, I update the EndeavourOS mirrors, it asks me for my password and tells me to press enter to exit (everything is correct in this case).

I forgot to mention that I learned how to update mirrors by watching video tutorials, so maybe I’m not doing it the right way.

I read that activating the mirror of your country and Worldwide was enough.

1 Like

I adopted your settings and also got an error


@manuel Maybe you should take a look at it.

try arch rate mirrors (the second button) in the welcome app. that should work.

1 Like

That was already done correctly, I tried a few countries and it worked, if you chose Spain an error message popped up.

1 Like


rate-mirrors arch | sudo tee /etc/pacman.d/mirrorlist

to generate a new mirrorlist and

sudo pacman -Syyu

to update your system.

If all goes well, install flatpak:

sudo pacman -S flatpak

If anything goes wrong, post the whole terminal output.


@nicknick ahhh I just see it now, our welcome app’s are different. You are missing arch rate mirrors.


1 Like

Thank you very much friend, I unchecked my country (Spain) and left only Wolrdwide, and now I can use YAY, I have been able to update all the EndeavorOS packages without problem.

It seems that there is some error with the Spanish mirrors. I updated them several weeks ago, but I think Welcome was updated recently, maybe that could be the error (I don’t know, I’m new to Linux).

Thanks friend, I’ll try to install flatpak now!

1 Like

Sorry friend, I hadn’t seen your message until now. It works again just by checking Worldwide.

Should I still use your command, or is it not necessary since everything works correctly now?

Yes it isn’t in my welcome app either.

To do this you will have to install rate-mirrors.


No, if everything works.

Just update your system fully before installing any new package.


Wait, it’s true! Why doesn’t my EndeavourOS have this option?

My EndeavourOS has everything default, I only installed the KDE desktop, I have been using Linux for I think less than 2 months and I never saw that button.

I did a basic installation of EndeavourOS, the only thing I selected was KDE.

Well I’m using the Global Theme Sweet KDE, but everything else is an EndeavourOS KDE with default settings.

Maybe the EndeavourOS ISO was updated or something and that’s why my Welcome doesn’t have that third button.

I think it may be because the package it uses isn’t installed and needs to be added from the AUR, just a guess though
EDIT - It is, after installing rate-mirrors it appears in the welcome app


That explains a lot, I forgot I installed it.

$ LANG=C yay -Qii rate-mirrors
Name            : rate-mirrors
Version         : 0.16.4-1
Description     : Everyday-use client-side map-aware mirror ranking tool
Architecture    : x86_64
URL             :
Licenses        : custom
Groups          : None
Provides        : None
Depends On      : gcc-libs
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 8,20 MiB                                                                                                                                                                    
Packager        : EndeavourOS <>                                                                                                                                          
Build Date      : Fr 28 Jul 2023 20:19:40 CEST                                                                                                                                                
Install Date    : Sa 29 Jul 2023 00:27:42 CEST                                                                                                                                                
Install Reason  : Explicitly installed                                                                                                                                                        
Install Script  : No
Validated By    : Signature
Backup Files    :


Oh I see! And what does that package do exactly, do you recommend I install it?

I don’t like installing AUR packages if it’s not strictly necessary since I’m a new user and I have to be careful, I prefer to download most things from the Arch repository.

But that package seems interesting, could you tell me what the package is called so I can install it from the terminal?

Although first I’m going to look for information to find out what it does, since I thought that the Update Mirrors default (the first button) ordered the rankings of the mirrors with the best ping in the world, when you checked Worldwide.

But it seems that that button you have does something similar.

1 Like