Error: failed to synchronize all databases (invalid or corrupted database (PGP signature))

I was updating with

sudo pacman -Syyu

But I get the following:

error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Synchronizing package databases...
endeavouros                   32.4 KiB  50.9 KiB/s 00:01 [------------------------------] 100%
core                           8.5 KiB  6.67 KiB/s 00:01 [------------------------------] 100%
extra                          8.5 KiB  6.65 KiB/s 00:01 [------------------------------] 100%
community                      8.5 KiB  5.76 KiB/s 00:01 [------------------------------] 100%
multilib                       8.5 KiB  6.65 KiB/s 00:01 [------------------------------] 100%
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: failed to synchronize all databases (invalid or corrupted database (PGP signature))

I tried this as per https://wiki.archlinux.org/title/Pacman … r:_No_data

rm -r /var/lib/pacman/sync/

But yet nothing works sad

Installing packages doesn’t work either

sudo pacman -S archlinux-keyring

error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: database ‘core’ is not valid (invalid or corrupted database (PGP signature))
error: database ‘extra’ is not valid (invalid or corrupted database (PGP signature))
error: database ‘community’ is not valid (invalid or corrupted database (PGP signature))
error: database ‘multilib’ is not valid (invalid or corrupted database (PGP signature))

Welcome @rynite to the good ship :enos:
What happens if you just try yay ?

Thanks,

here’s the output

error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Synchronizing package databases…
endeavouros is up to date
core 8.5 KiB 13.0 KiB/s 00:01 [------------------------------] 100%
extra 8.5 KiB 12.9 KiB/s 00:01 [------------------------------] 100%
community 8.5 KiB 12.9 KiB/s 00:01 [------------------------------] 100%
multilib 8.5 KiB 12.6 KiB/s 00:01 [------------------------------] 100%
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: failed to synchronize all databases (invalid or corrupted database (PGP signature))
→ error installing repo packages

Try the steps in the post below. It resolved a similar issue with:

for the OP in that thread.

I already tried that before, it doesn’t work I still get the same errors

1 Like

Did you try refreshing your mirrorlist?
You could do that from the Welcome app or using reflector command line:

https://wiki.archlinux.org/title/Reflector

After generating a new mirrorlist, try again:

sudo pacman -Syyu

I tried both of these
image

unfortunately… same results…

1 Like

Potentially solved by this post on Arch Linux BBS?

First make sure the first mirror in [sudo nano /etc/pacman.d/mirrorlist] is whitelisted

Then:

sudo rm -R /var/lib/pacman/sync

If you use e2guardian, make sure ‘blanket block for SSL’ is not enabled in [examplef1.story].
Then

sudo -E pacman -Syu

If no solution for you, see this:
https://wiki.parabola.nu/Pacman_troubleshooting#.22GPGME_error:_No_data.22_Error

1 Like

I refreshed my mirrors once again and removed the sync folder then tried pacman -Syyu. and now it works perfectly fine, thank you :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.