Error Failed to start: Remount Root and kernel file system

Like the title says i get this error " Failed to start: Remount Root and kernel file system" every time i boot my pc.
The pc works fine but i wanted to fix this error for the sake of it.

I searched and the only good thing i found was to reinstall grub but it didn’t fix the probem.

Can anyone help me with this?

Hi, please show me some informations about your system, type the following commands:

sudo fdisk -l
cat /etc/fstab
ls -l /dev/disk/by-uuid/

From sudo fdisk -l

Disk /dev/nvme0n1: 476,94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: SAMSUNG MZVLB512HBJQ-000L2              
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 5EC0E05A-9BCF-4AD9-A54A-EFA49AC1CCFC

Device            Start        End   Sectors   Size Type
/dev/nvme0n1p1       34    2050047   2050014  1001M EFI System
/dev/nvme0n1p2  2050048   12290047  10240000   4,9G Linux swap
/dev/nvme0n1p3 12290048 1000215182 987925135 471,1G Linux filesystem


Disk /dev/sda: 28,65 GiB, 30765219840 bytes, 60088320 sectors
Disk model: Ultra USB 3.0   
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6d939b21

Device     Boot Start     End Sectors  Size Id Type
/dev/sda1  *        0 5129503 5129504  2,4G  0 Empty
/dev/sda2         252  409851  409600  200M ef EFI (FAT-12/16/32)

From cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=D74E-99EB                            /boot/efi      vfat    umask=0077 0 2
UUID=099923f8-56fe-42a3-80ec-0bb1f5d33abd swap           swap    defaults,noatime 0 0
UUID=77c3193b-3a4d-4d34-b2e3-50c00a4bdb90 /              btrfs   subvol=/@,defaults,noatime,space_cache,autodefrag 0 0
UUID=77c3193b-3a4d-4d34-b2e3-50c00a4bdb90 /home          btrfs   subvol=/@home,defaults,noatime,space_cache,autodefrag 0 0
UUID=77c3193b-3a4d-4d34-b2e3-50c00a4bdb90 /var/cache     btrfs   subvol=/@cache,defaults,noatime,space_cache,autodefrag 0 0
UUID=77c3193b-3a4d-4d34-b2e3-50c00a4bdb90 /var/log       btrfs   subvol=/@log,defaults,noatime,space_cache,autodefrag 0 0

From ls -l /dev/disk/by-uuid/

total 0
lrwxrwxrwx 1 root root 15 mar  1 18:28 099923f8-56fe-42a3-80ec-0bb1f5d33abd -> ../../nvme0n1p2
lrwxrwxrwx 1 root root 10 mar  1 18:28 2022-01-31-14-51-45-00 -> ../../sda1
lrwxrwxrwx 1 root root 15 mar  1 18:28 77c3193b-3a4d-4d34-b2e3-50c00a4bdb90 -> ../../nvme0n1p3
lrwxrwxrwx 1 root root 10 mar  1 18:28 B6CA-08F0 -> ../../sda2
lrwxrwxrwx 1 root root 15 mar  1 18:28 D74E-99EB -> ../../nvme0n1p1

uuid in the fstab look’s ok. maybe grub is the reason for the boot fail. you have try to reinstall grub?

Edit: please show me the result from the following command.

cat /boot/grub/grub.cfg

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod btrfs
search --no-floppy --fs-uuid --set=root 77c3193b-3a4d-4d34-b2e3-50c00a4bdb90
    font="/@/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=1920x1080,auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_GB
  insmod gettext
fi
terminal_input console
terminal_output gfxterm
insmod part_gpt
insmod btrfs
search --no-floppy --fs-uuid --set=root 77c3193b-3a4d-4d34-b2e3-50c00a4bdb90
insmod gfxmenu
loadfont ($root)/@/usr/share/grub/themes/Graphite/dejavu_sans_12.pf2
loadfont ($root)/@/usr/share/grub/themes/Graphite/dejavu_sans_14.pf2
loadfont ($root)/@/usr/share/grub/themes/Graphite/dejavu_sans_16.pf2
loadfont ($root)/@/usr/share/grub/themes/Graphite/dejavu_sans_24.pf2
loadfont ($root)/@/usr/share/grub/themes/Graphite/dejavu_sans_32.pf2
loadfont ($root)/@/usr/share/grub/themes/Graphite/dejavu_sans_48.pf2
loadfont ($root)/@/usr/share/grub/themes/Graphite/terminus-12.pf2
loadfont ($root)/@/usr/share/grub/themes/Graphite/terminus-14.pf2
loadfont ($root)/@/usr/share/grub/themes/Graphite/terminus-16.pf2
loadfont ($root)/@/usr/share/grub/themes/Graphite/terminus-18.pf2
insmod png
set theme=($root)/@/usr/share/grub/themes/Graphite/theme.txt
export theme
if [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=5
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=5
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/06_grub-customizer_menu_color_helper ###
### END /etc/grub.d/06_grub-customizer_menu_color_helper ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch Linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-77c3193b-3a4d-4d34-b2e3-50c00a4bdb90' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod btrfs
        search --no-floppy --fs-uuid --set=root 77c3193b-3a4d-4d34-b2e3-50c00a4bdb90
        echo    'Loading Linux linux ...'
        linux   /@/boot/vmlinuz-linux root=UUID=77c3193b-3a4d-4d34-b2e3-50c00a4bdb90 rw rootflags=subvol=@  quiet resume=UUID=099923f8-56fe-42a3-80ec-0bb1f5d33abd loglevel=3
        echo    'Loading initial ramdisk ...'
        initrd  /@/boot/intel-ucode.img /@/boot/amd-ucode.img /@/boot/initramfs-linux.img
}
submenu 'Advanced options for Arch Linux' $menuentry_id_option 'gnulinux-advanced-77c3193b-3a4d-4d34-b2e3-50c00a4bdb90' {
        menuentry 'Arch Linux, with Linux linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-advanced-77c3193b-3a4d-4d34-b2e3-50c00a4bdb90' {
                load_video
                set gfxpayload=keep
                insmod gzio
                insmod part_gpt
                insmod btrfs
                search --no-floppy --fs-uuid --set=root 77c3193b-3a4d-4d34-b2e3-50c00a4bdb90
                echo    'Loading Linux linux ...'
                linux   /@/boot/vmlinuz-linux root=UUID=77c3193b-3a4d-4d34-b2e3-50c00a4bdb90 rw rootflags=subvol=@  quiet resume=UUID=099923f8-56fe-42a3-80ec-0bb1f5d33abd loglevel=3
                echo    'Loading initial ramdisk ...'
                initrd  /@/boot/intel-ucode.img /@/boot/amd-ucode.img /@/boot/initramfs-linux.img
        }
        menuentry 'Arch Linux, with Linux linux (fallback initramfs)' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-fallback-77c3193b-3a4d-4d34-b2e3-50c00a4bdb90' {
                load_video
                set gfxpayload=keep
                insmod gzio
                insmod part_gpt
                insmod btrfs
                search --no-floppy --fs-uuid --set=root 77c3193b-3a4d-4d34-b2e3-50c00a4bdb90
                echo    'Loading Linux linux ...'
                linux   /@/boot/vmlinuz-linux root=UUID=77c3193b-3a4d-4d34-b2e3-50c00a4bdb90 rw rootflags=subvol=@  quiet resume=UUID=099923f8-56fe-42a3-80ec-0bb1f5d33abd loglevel=3
                echo    'Loading initial ramdisk ...'
                initrd  /@/boot/intel-ucode.img /@/boot/amd-ucode.img /@/boot/initramfs-linux-fallback.img
        }
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
menuentry 'UEFI Firmware Settings' $menuentry_id_option 'uefi-firmware' {
        fwsetup
}
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg
fi
### END /etc/grub.d/41_custom ###

I wonder if

systemctl status systemd-remount-fs.service

can give some more clue? Could you post the output?

Also:

UUID=099923f8-56fe-42a3-80ec-0bb1f5d33abd swap           swap    defaults,noatime 0 0

should be

UUID=099923f8-56fe-42a3-80ec-0bb1f5d33abd none          swap    defaults,noatime 0 0

in /etc/fstab.

× systemd-remount-fs.service - Remount Root and Kernel File Systems
     Loaded: loaded (/usr/lib/systemd/system/systemd-remount-fs.service; enabled-runtime; vendor preset: disabled)
     Active: failed (Result: exit-code) since Tue 2022-03-01 21:15:31 WET; 44s ago
       Docs: man:systemd-remount-fs.service(8)
             https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
    Process: 467 ExecStart=/usr/lib/systemd/systemd-remount-fs (code=exited, status=1/FAILURE)
   Main PID: 467 (code=exited, status=1/FAILURE)
        CPU: 4ms

mar 01 21:15:31 lighttigerXIV-Arch systemd[1]: Starting Remount Root and Kernel File Systems...
mar 01 21:15:31 lighttigerXIV-Arch systemd-remount-fs[476]: mount: /: mount point not mounted or bad option.
mar 01 21:15:31 lighttigerXIV-Arch systemd-remount-fs[467]: /usr/bin/mount for / exited with exit status 32.
mar 01 21:15:31 lighttigerXIV-Arch systemd[1]: systemd-remount-fs.service: Main process exited, code=exited, status=1/FAILURE
mar 01 21:15:31 lighttigerXIV-Arch systemd[1]: systemd-remount-fs.service: Failed with result 'exit-code'.
mar 01 21:15:31 lighttigerXIV-Arch systemd[1]: Failed to start Remount Root and Kernel File Systems.

what is your current arch linux version?

This says something about mount point for / or the mount options but unfortunately I can’t make anything of it :blush:
Perhaps some other forummember might have some idea.

1 Like

I am no expert on btrfs, but I think fstab subvol entries should not include slash.

The error message says

2 Likes

i found an example btrfs fstab file, the argument subvol= was 2x for every partition, one with slash and one without, like this ‘subvol=/@home,subvol=@home’:

1 Like

This is the more relevant part of the fstab line for the root subvolume generated by genfstab in an Arch install:

subvol=/@,defaults,noatime,space_cache,compress=zstd 0 0

The slash was added by genfstab itself.

2 Likes

Try to remove space_cache mount option from fstab.
(Every line and make a backup from the file before edit)

space_cache gives an error on my vm machine:


and when I delete it, the mount goes through.

2 Likes

Yup. That worked for me. Thank you :smiley:

2 Likes

space_cache (v.1.0) is default mount option.
https://btrfs.readthedocs.io/en/latest/btrfs-man5.html

1 Like

My interpretation of this man is that removing space_cache is equivalent to the default, thus OP changed to the same mount option (or I am reading this wrong…). It seems that using nospace_cache actually disables space_cache.

… That’s why I don’t use btrfs…:exploding_head:

I just went to /etc/fstab and removed all the space_cache options and it worked.

alternatively you can try this option space_cache=v2

You are right, nospace_cache disable it.

I think that’s a bug. At least something bug-like.
Specifying a default setting should not cause the error.

And even despite this I use btrfs on root…
But each in their own way. :slightly_smiling_face:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.