"error: failed to commit transaction" error while updating eOS

When updating my system with the sudo pacman -Syu command, everything goes normally at first, but after all the latest updates are completed

error: libldap: signature from "Frederik Schwan <freswa@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libldap-2.6.4-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

it gives 30-40 similar error messages, I call them all ‘y’. At the end:

error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

It gives an error and the update fails. I searched a bit on the internet and tried several methods but none of them worked. How can I solve this?

1 Like

I would update the mirrors and then try the update again.

Edit: You may also need to select another country for mirror list if it keeps failing.

Welcome to the forum! :smile:

Try: eos-update

and update keyring package first and do the full update after this
sudo pacman -Sy archlinux-keyring

1 Like

this will do it simpler :wink:


i tried it but it didn’t work.

I updated the mirrors and ran the full system update but it didn’t work. Now I will choose another country for the mirror list and try again.

whats the first mirror in your mirrorlist?

In line with what @joekamprad said, can you show the output of command

cat /etc/pacman.d/mirrorlist | eos-sendlog

and tell in which country you are running the machine?

Output of cat /etc/pacman.d/mirrorlist | eos-sendlog:


I’m running my machine in Turkey.

I have only United States and Germany servers in the mirror list.

## Worldwide
Server = https://geo.mirror.pkgbuild.com/$repo/os/$arch

i would not put these…

I forgot to mention Worldwide. Sorry.

running bthis should renew all keys from archlinux if not it should gave errors on output

Its not gave errors. Take a look.

:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
warning: archlinux-keyring-20230504-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Package (1)             Old Version  New Version  Net Change

core/archlinux-keyring  20230504-1   20230504-1     0,00 MiB

Total Installed Size:  1,61 MiB
Net Upgrade Size:      0,00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                        [--------------------------------------] 100%
(1/1) checking package integrity                                      [--------------------------------------] 100%
(1/1) loading package files                                           [--------------------------------------] 100%
(1/1) checking for file conflicts                                     [--------------------------------------] 100%
:: Processing package changes...
(1/1) reinstalling archlinux-keyring                                  [--------------------------------------] 100%
==> Appending keys from archlinux.gpg...
==> Updating trust database...
gpg: next trustdb check due at 2023-06-15
==> Updating trust database...
gpg: next trustdb check due at 2023-06-15
:: Running post-transaction hooks...
(1/3) Reloading system manager configuration...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Checking which packages need to be rebuilt


Thank you so much! It works.

1 Like

somehow last resort :wink:
seems this can happen it was already on latest keyring package but looked like keys or signatures where not matching…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.