Error disk not found, grub rescue

Hi, for a couple of months I ran a dualboot with windows, but a couple of days ago i decided to increase the size of the linux partition (I struggled a bit but in the end I managed to do it). This caused every time i booted up my system to show error unknown filesystem. entering rescue mode grub rescue> so every time I had to type set root, set prefix… To fix that I found online to run this two commands: sudo grub-mkconfig -o /boot/grub/grub.cfg sudo grub-install --recheck --disk-module=native /dev/sda which the second outputted something like no problems found. But this fucked something up because every time i boot up the system I have: error: no such device: error: disk ``' not found. Entering rescue mode... grub rescue>

Idk what to do luckily I’ve been able to run a live usb and also to access the files on my laptop.
Thanks in advance for any help.

Launch your live usb and post the output of the following commands:

sudo parted -l
efibootmgr
Model: Kingston DataTraveler 3.0 (scsi)
Disk /dev/sda: 124GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 2      2595MB  2760MB  165MB  primary  fat16        esp


Model: KBG50ZNV512G KIOXIA (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  274MB  273MB   fat32        EFI system partition          boot, esp
 2      274MB   290MB  16.8MB               Microsoft reserved partition  msftres
 3      290MB   361GB  361GB                Basic data partition          msftdata
 4      361GB   511GB  150GB   ext4         endeavouros
 5      511GB   512GB  645MB   ntfs         Basic data partition          hidden, diag, no_automount

BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0004,0000,0001,0002,0003
Boot0000* endeavouros   HD(1,GPT,d663b595-7515-4711-bfd7-33c99ac3f85c,0x800,0x82000)/File(\EFI\endeavouros\grubx64.efi)
Boot0001* Windows Boot Manager  HD(1,GPT,d663b595-7515-4711-bfd7-33c99ac3f85c,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0002* Internal Hard Disk    PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/NVMe(0x1,8C-E3-8E-04-03-F5-05-41)/HD(1,GPT,d663b595-7515-4711-bfd7-33c99ac3f85c,0x800,0x82000)0000424f
Boot0003* USB Drive (UEFI) - KingstonDataTraveler 3.0PMAP       PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x4)/USB(5,0)/CDROM(1,0x4d5940,0x4ea98)0000424f
Boot0004* USB Drive (UEFI) - KingstonDataTraveler 3.0PMAP       PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x4)/USB(5,0)/HD(2,MBR,0x4e4305b5,0x4d5940,0x4e800)0000424f

1 Like

Judging by the output, you have a GPT disk and an installation in UEFI mode.

The grub-install command that you have run before is aimed for Legacy/Bios installations and also seems to be targeting the wrong disk: your live usb rather than the system disk.

You could try reinstalling the Grub’s bootlader in the chroot.

To chroot:

sudo mount /dev/nvme0n1p4 /mnt
sudo mount /dev/nvme0n1p1 /mnt/boot/efi
sudo arch-chroot /mnt

In chroot:

grub-install
grub-mkconfig -o /boot/grub/grub.cfg

Also check if the UUID for your partitions corresponds to the ones in /etc/fstab.

You could run lsblk -f to get the UUID:s.

If they don’t match, edit /etc/fstab accordingly.

If everything is fine, type exit to quit chroot and reboot.

It worked, thank you SO much

1 Like

You are welcome! Glad you got it working!

And also, welcome to EnOS’ community @DMttn18!

:enos: :handshake:t5:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.