Error calling StartServiceByName for org.freedesktop.Notifications: Timeout was reached

Whenever I spot an update that will need a reboot (and most other times too), I log out of KDE Plasma, open tty2 and then run yay again and choose “y”. Every time that the message “Reboot is recommended” appears, there is a long pause, and then “Error calling StartServiceByName for org.freedesktop.Notifications: Timeout was reached” appears, and there is another long pause.

This happened again just now with the mesa update.

I’ve done some searches (DDG, Goolag) and can find various “Error calling StartServiceByName” mentions, but none for my own set of circumstances. Which log file should I be looking at? Am I missing a package? Is anyone else experinencing this?

Probably because the TTY is not graphical, the update notifier tries to send the update requires a reboot message but cannot as there is no gui.

Hope that makes sense!!!


What happens when you run eos-update-notifier from the menu? Does it give you the same error message?

1 Like

That does make some sense. Thank you.

I’ll try running

as @ricklinux suggests next time, and report back.

The virtualbox and virtualbox-host-dkms came through for me just now, so I tried using the “UpdateInTerminal” shortcut in the menu and… the terminal notified me that “Reboot is recommended” with no pause.

So I’m going to assume for now that it is related to using a tty.

Thank you both @xircon and @ricklinux

Today’s systemd update provided the opportunity to try UpdateInTerminal in a tty, with the result of the same pauses and error message as yay in a tty.

I still might use the tty method for some significant updates, as I’m more comfortable updating those packages with as little running as possible, but I accept that I’ll just have to lump the pauses and error message.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.