Error boot after nvidia update : Stuck on reached target graphical interface

Today I updated my endeavourOS. The installation updated Nvidia-extra. And now after a reboot I’m stuck on boot screen with this step as the latest : Stuck on reached target graphical interface.

My hardware :

Doing Ctrl+alt+F3 worked and redirected me to a new terminal. How can I fix this error.

1 Like

I tried launch KDE Plasma put I get the same error again and again :

And here are my packages linked to nvidia. I don’t find nvidia-extra in them. Maybe I watched it wrong when I updated

I found the solution doing a rollback for both Nvidia and nvidia-utils :

1 Like

This version of nvidia seems to be bugged with KDE Plasma. Do you know why ? Should I wait for the next release of it or is it a local install problem ?

I made the same update today on KDE with no problems, so I’m not sure what happened in your case.

1 Like

It’s not just KDE, I’m on cinnamon and just did the update, now steam won’t launch, it gets stuck on loading user data. Rolling back fixed everything, this is the second nvidia driver update out of the past 4 to break something critical.

My list is much different than yours:

$ yay -Qs nvidia
local/egl-wayland 2:1.1.12-1
    EGLStream-based Wayland external platform
local/lib32-nvidia-utils 535.86.05-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl 535.86.05-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 535.86.05-2
    NVIDIA drivers - module sources
local/nvidia-hook 1.3-1
    pacman hook for nvidia
local/nvidia-inst 23-6
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-installer-common 23-6
    Common scripts for nvidia-installer-dkms and nvidia-inst
local/nvidia-utils 535.86.05-2
    NVIDIA drivers utilities

How did you update the system?

Same thing has happened to me on xfce.

I tried to rollback nvidia-dkms and nvidia-utils but I get an error

“failed to prepare transaction (could not satisfy dependencies)
installing nvidia-utils (535.54.03-1) breaks dependency ‘nvidia-utils=535.86.05’ required”

1 Like

Just ran yay command. Followed this guide : A Complete Idiot's Guide To Endeavour OS Maintenance / Update / Upgrade

1 Like

Maybe a problem with my hardware specifically. I don’t know

Thanks for the page, I bookmarked it.

I tried a few things, but still no desktop. I explicitly installed nvidia-utils and nvidia-dkms which both completed without error, but it made no difference.

I have an older GeForce GTX 1060, 3GB, if that matters.

Edit: After today’s kernel update I’m able to boot into xfce again. I would still like to understand what happened.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.