Error at system startup

When the system starts, the following messages are displayed to me:

`kernel: __common_interrupt: 1.55 No irq handler for vector

kernel: __common_interrupt: 2.55 No irq handler for vector

kernel: __common_interrupt: 3.55 No irq handler for vector

kernel: kvm: disabled by bios

kernel: kvm: disabled by bios

kernel: kvm: disabled by bios

kernel: kvm: disabled by bios`

This error does not slow my system down. I looked into the BIOS and I don’t know what this quadruple kvm information is about, because I didn’t find anything about it in the BIOS. I have an HP EliteBook745 Processor Type: AMD A8 PRO-7150B R5, 10 Compute Cores 4C + 6G.
What can you do with it?

Hello @Kxliner
There should be a setting in the Bios to enable support for virtual (kvm) It’s probably under advanced and some submenu. You don’t really need to worry about it unless you are running vm’s. It’s just reporting information. Same with the No irq handler for vector. You can check if there is a Bios update for your motherboard that possibly may fix that but it’s not really a problem. I had it on mine which is fairly new hardware and a new UEFI (Bios) update got rid of that messaging about No Irq for vector handling.

I updated the BIOS twenty days ago on April 26th. Nothing has changed. I don’t use virtual machines.

The message No irq handler for vector was there before your Bios update or you just noticed it now? Like i say it doesn’t really affect anything.

I tried to update the BIOS but the latest version is from 2016 and it was already in the system. No irq handler for vector was and still is. It’s okay with me. I just wanted to know what it is.

I was told this was an AMD Ryzen error and we must not worry. :thinking:

Perhaps these shed some light?


Maybe they shed some light, but to understand it you have to have knowledge that I do not have yet. I will not do IT studies anymore, because I finished high school 41 years ago. I just wanted to know how this message can be turned off.

This is essentially the same as asking why a “check engine” light has lit up on your car dashboard but only wanting to know how to disable the warning. :man_shrugging:

It is possible to add a kernel parameter to the default grub command line and generate a new grub boot file. You would have to try it and there are a few different ones that you could try but, sometimes a kernel parameter doesn’t work or introduces other issues. So you have to try it basically trial & error. See if it works or not and doesn’t cause any additional problems.

You could try adding in this parameter in the default grub command line after “quiet”

sudo nano /etc/default/grub


Save the file after adding and generate a new grub boot file
ctrl + o then enter to save
ctrl + x to exit

Generate a new grub file.
sudo grub-mkconfig -o /boot/grub/grub.cfg

Reboot and see if the error messages are gone and also if there are any issues caused by the parameter. This may or may not solve your concern. I would also keep an eye out for additional Bios updates. If doing another Bios update you would have to remove the kernel parameter to check if the Bios update fixed this issue.

On my Ryzen board i didn’t have this issue in the beginning but a UEFI (Bios) update introduced it. Later a newer UEFI update got rid of it again. My hardware is fairly new and I am waiting on another UEFI update that is in Beta right now. Hopefully it doesn’t bring it back. :slightly_smiling_face:

Always keep in mind that as you get updates such as Linux firmware and kernels things may change. So at some point no problems now could be a problem later or vice versa. So removing it and checking is possible down the road but also if it’s not causing any problem the parameter doesn’t hurt. You just have to figure out if it is or isn’t. Hope this helps.

Edit: Also keep in mind that some kernel parameters cause the computer not to boot or other issues.

I did what you wrote to me. After rebooting, No irq handler for vector was gone, but the system was loading for a long time and the keyboard was not working.

This is exactly what i was saying. Sometimes it introduces other issues. There are other kernel parameters you could try. Just remove that one and regenerate a new grub file and you’ll be back to where you were. You could try.


As i say it’s a trial & error or fixed with a Bios update.

As I wrote, my latest BIOS version is from 2016. There is no update any more, because I tried to do it on April 26th.

I’m just saying maybe a future update? Might come! Or a new kernel and or other updates that might fix it. It’s possible.

Edit: Just keep in mind that not all messaging is errors. Some of it is just information.

Yes you are right. Let it be that way. It’s okay with me.