EoS won't boot anymore

So i installed EoS a couple days ago, used Manjaro for about a year or so. I used pacman to install my stuff mostly, 2-3 using yay for kwin-bismuth and later after a few restarts timeshift and timeshift-autosnap maybe also Steam on the same session, then the next day when i tried booting i got this:

I waited for about 30 minutes, i see this screen on on EoS all the time and same for Manjaro, sometimes it took up to 15 minutes on Manjaro, nothing unusual, but this time 30 minutes and still nothing probably means it won’t boot, i restarted a few times after that and it still wouldn’t boot.

System info:

lib32-nvidia-utils 510.54-1
Operating System: EndeavourOS
KDE Plasma Version: 5.24.3
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.3
Kernel Version: 5.16.14-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 2700X Eight-Core Processor
Memory: 15,6 GiB of RAM
Graphics Processor: NV134

journalctl --directory=/run/media/kiloneie/e792ef30-9a7c-4845-99d5-92b981330afa/var/log/journal




Tell me if i need to provide you with the log files themselves, and which ones, not knowledgeable on this.

I hope the information is good now.

Please wait for the arrival of the forum’s experts.
Good luck!

1 Like

It seems your last pacman package update did not complete normally.

You should chroot to your system and run a full update again.

What is your actual graphics card GTX 1070? Or other? Did you install the nvidia drivers?

Edit: I’ll rephrase the question. Did you use the default entry on the grub menu when you installed or the non free nvidia?

Edit2: I think you should try what @petsam suggests above.

1 Like

I got 2 gpus in the system 1070 Ti and 1060 3GB(was meant for GPU passtrough, it didn’t work, it’s just there powering my second monitor). Pretty sure i used all the defaults, pretty sure EoS doesn’t ship Nvidia drivers, i recall some part of installing it yes.

Okay i will try that “chroot” link you sent. I can do this from any linux distro right ? Manjaro/live usb ?

Yes you can use the live ISO.

Just to let you know the default grub entry on the EOS live ISO will install the system with opensource nouveau driver if you have nvidia graphics. The nonfree nvidia entry will automatically install nvidia drivers. Alternatively you can install the nvidia drivers after the install if that is what you did.

Edit: I know this isn’t related to your current issue but just information for you.

Yes i saw that on EoS live usb image, though how do i know which drivers EoS is using ?

Back on topic, i followed that video, used EoS live usb image, used sudo fdisk -l to locate my drive, mounted the 2 partitions out of 3(third is swap) of my nvme drive of EoS, arch-chroot /mnt into EoS, did sudo pacman -Syu, it updated, tried unmounting which didn’t work/later it seemed to have auto unmounted but whatever → additional line on screen of smthing handler, no boot. So i went back into the live image and did pacman -Syu again, nothing to do, removed timeshift and timeshift-autosnap via pacman -Rs, rebooted and still no boot.

Updated logs:




(If they changed at all…)

Since updating didn’t work what about reinstalling grub and updating grub using the arch-chroot process.

Did you save the snapshots?
If you save, you could try going back to the previous working one,
if you had time to create one before the updates.

Sadly no, i simply installed timeshift and timeshift-autosnap and then shutdown pretty much.

Okay i will try to reinstall and update grub.

EDIT; So via arch-chroot went into EoS and did sudo pacman -Syu grub, it reinstalled, tried booting, nothing. Tried also grub-install --target=i386-pc /dev/sdX but that seems to be a archlinux manual install thing, didn’t do anything.

Edit2; About the drivers; using lspci -v i see nouaveu being in use, im guessing just installing the lib32 nvidia something doesn’t quite do it.
Will this work ? sudo pacman -S nvidia-installer-dkms

Worth checking just in case there’s something useful:

Yeah sadly no, updating mirrors just times out into infinity, ‘sudo dkms autoinstall’ gives dkms command not found, i don’t think it’s meant to be run from chroot.

Which drivers do you have installed? Or rather, which drivers did you think you had installed?

If DKMS is missing and you were using nvidia-dkms then it’s likely the drivers are not installed, in which case you should reinstall them.

It is.

Imma do this then; sudo pacman -S nvidia-installer-dkms

EDIT; that was super tiny and quick… i installed lib32-nvidia-utils yesterday i think, but it still used nouvaeu. What did this even do ? The above.

That’s not the drivers, that’s a tool that tells you which drivers are compatible.

The package I wrote above is the driver package:

1 Like

WTF, how did this fix it !? This makes no sense…

If the problem is that you removed the NVIDIA drivers then try reinstalling them from inside the chroot:

pacman -Syu nvidia-dkms