EOS VirtualBox hosting Windows guest: host-only networking

To get a “EOS VirtualBox hosting Windows guest: host-only networking” to work from scratch, the below steps were taken.
The objective is to access through the EOS FileManger under Gnome smb://??? a drive inside the Windows guest.

  1. VB: Tools / Network Manager
  2. VB: VM Settings
  3. VM: Control Panel, Network, Adapter Properties
  4. Samba
yay samba
sudo touch /etc/samba/smb.conf
sudo systemctl status smb
smbclient -L hostname -U%

Here, I am stuck. Any advice is welcome.

I am currently on my phone so I cant fully see those settings but it looks like you gave the host and the guest the same IP address.

They need to be different. Also, you dont need a default gateway on the guest.

Appreciate. Setting in the Windows guest are amended.

I am not sure how to get the samba portion on the EOS host to work…

Really? A host-only looks like that.

A default gateway lets your VM know how to get to other networks.

In a host-only network, there is no access to other networks so a default gateway isn’t needed.

Sorry, I have confused some settings and close this thread. I will post again, when the problem is more clear cut. Thank you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.