EOS tells me my password is incorrect when trying to unlock after manual lock (Super-L). Restarting fixes i

EOS tells me my password is incorrect when trying to unlock after manual lock (Super-L). Restarting fixes this. However, if I use the automatic screenlock only, and let the screen lock itself automatically (after time preset in privacy settings), then I can unlock it with password. It only happens when I manually lock my laptop?

What DE are you using? What command is linked to your key shortcut super+L?

Gnome… Super L locks screen. But if I put password always says error password even though is correct password multiple times. Capslock is off. However if same happens automatically with screen lock and not manually locked the password works.

Are you using

gnome-screensaver-command -l

by pressing super + L?

Is it possible that you are switched to an English keyboard layout when your lockscreen is activated? Could you try and type your password by pressing the keys that would be the equivalent on an English keyboard layout?

Not sure what you mean,…,I always use an English keyboard…I havent changed anything post install. The Super-L (Windows key + L key ) always locks the screen manually on gnome on Ubuntu and EOS.

so I did’nt use this

[quote=“PigOfDestiny, post:4, topic:40060”]
gnome-screensaver-command -l
[/quote] as a custom short cut

It’s just strange when I manually lock the password does not unlock. I have to reboot. However if the screen locks automatically (after time set) then I can always unlock fine.

Well if you are anyways using an English keyboard layout never mind. But there are different keyboard layouts and if the layout of the OS doesn’t match the printed signs on the keyboard it can lead to some confusion.

Could you then please try if you have the same issue when you lock the screen using this command:

gnome-screensaver-command -l

It is necessary to know what is executed when you press super+L

I get

bash: gnome-screensaver-command: command not found

Apparently gnome-screensaver is not installed. Can you try

 dbus-send --type=method_call --dest=org.gnome.ScreenSaver /org/gnome/ScreenSaver org.gnome.ScreenSaver.Lock

I never used gnome and I don’t understand why I have such a hard time to find through google what is used by default to lock the screen and why it apparently is not so obvious to check it from the system itself. Very awkward for a Linux DE in my opinion.

Agreed. AFAIK all Gnome laptops before if I press Super+L I can manual screen lock, but being able to unclock only happens on EOS now, not Ubuntu or Pop before.

So yes that locks the screen and I can unlock after doing that. So how to use this to resolve now? Do I add that to custom keyboard shortcut or something? or just install Gnome (legacy) Screensaver?

If possible I would change the key binding for Super+L or deactivate that and link the command to another key combination like Alt+L.
Again I tried to google how to do that. All I could find was that:

If it doesn’t work with gnome onboard tools I guess I would try xbindkeys (https://wiki.archlinux.org/title/Xbindkeys)

In general I would think that it should be possible with gnome onboard tools. At least I don’t know any other DE that makes it impossible to change or create keybindings.

Don’t know if I would use the legacy screensaver. It appears to be abandoned by the gnome project.

@pebcak You use Gnome, right? Do you know by any chance how to edit/create custom keybindings?


In Settings > Keyboard > View and Customize Shortcuts > (for this case) > System > Lock Screen

You could then set a new shortcut or press Backspace to disable it.

For making a new shortcut: Custom Shortcut > +


As a temporary solution I just set a new custom keyboard shortcut using “Alt+L” with the custom command

 dbus-send --type=method_call --dest=org.gnome.ScreenSaver /org/gnome/ScreenSaver org.gnome.ScreenSaver.Lock

I dont need to disable the Super+L , I can just use the Alt+L for now until it is resolved. Its funny because the Super+L screenlock works fine on Ubuntu Gnome on my other laptops. The workaround you suggested is fine for now. Tks.


This is not going to resolve your issue but Super+L works fine on my end on Arch-GNOME.
I can unlock the screen with my password without problem.

1 Like

Did you have to adjust permissions for it to work?

1 Like

No, nothing.
I did test on two systems, both Arch-GNOME and it did work on both with no issues.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.