EOS sound issue for Panasonic Toughbook CF-19


I am a relatively new User of EOS and Arch Linux in general. I have it installed on my work computer (which is one of the newest Lenovo Thinkpads and runs without issues), while I have Garuda on my gaming laptop.

Recently I am reviving an (not so) old Panasonic Thoughbook CF-19.

Specs from the Panasonic Website: https://www.panasonic.com/au/support/product-archives/computers-tablets-and-pos/notebook-tablet/toughbook-2-in-1-convertible-laptops/cf-19.specs.html

It used to have Linux Mint Debian Edition but I am now moving to Arch-based distros.

EOS installed successfully but this series of particular rugged Laptops from Panasonic have a small issue with the sound, in all Linux and BSD operating systems, that needs to be fixed manually.

For Linux Mint I have used the workaround provided here (in the “Fixing the Audio” section):

Although the instructions are meant for Ubuntu, they worked for me with Linux Mint and even with Fedora/RedHat-based distros.

As I am still new to Arch in general, I don’t know how to make a similar workaround with EOS for the sound in my Panasonic CF-19. The way Arch Linux handles the hardware is completely different and I am a bit confused while reading the Arch documentation.

Could anyone with a hardware similar to mine provide me a little help? Or probably someone who can help me “replicate” the specific sound configuration of the previous website from Ubuntu to Arch? I don’t really want to go back to Mint or Fedora to have sound working in my CF-19.

Thanks in advance!

EndeavourOS uses pipewire by default. You can switch to using pulseaudio instead of pipewire:


Then you can use the workaround you have previously used.

You may want to wait a bit, perhaps someone who has experience with this particular computer will know of a pipewire config that would work.

Also, if you could run inxi -A in your terminal and post the output, it will give some info about the computer’s audio that may be useful in getting pipewire working.

Hello! Thank you very much for your reply! Seems I will have to wait. I installed Hyprland on my EOS and currently cannot remove Pipewire as it is one of it dependencies.
This is the output of inxi -Aa

  Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: Matsushita driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
  API: ALSA v: k6.9.4-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off
    tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.7 status: active with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl

There has to be a way to make the sound works. Hopefully I am not the only one using an Arch-based distro on a Panasonic rugged laptop.

1 Like

Yo bto! :v:t6:

Check dis out https://wiki.archlinux.org/title/Panasonic_CF-SV9#Audio
Some other Panasonic requires alsa-firmware, maybe yours too!

Thanks for the suggestion. Will check if that applies to my Panasonic too. It is safe to install alsa/Pulseaudio stuff alongside Pipewire? There might be conflicts

UPDATE; Tried the alsa-firmware suggested last time. It installed some alsa packages but the sound was bugged. Even at 100% volume in all the settings panel the sound remained very low, like whispers, barely audible and with some random pips. So I reinstalled EOS, no Desktop environment, then sudo pacman -S pulseaudio and it removed pipewire without further issues. went to the pulseaudio config files as in the Ubuntu workaround mentioned early, modified JaKooLit’s Hyprland script so it doesn’t install pipewire, and finally have Hyprland, working sound and EOS on my Panasonic Thoughbook. :sweat_smile: Maybe another day I will “experiment” with pipewire but for now I have a working laptop again.