`eos-sendlog` not working

I do not get any output from eos-sendlog at all. It just returns without anything when provided stuff. When invoked with -h, it just hangs.
Here’s what my /usr/bin/eos-sendlog looks like. I haven’t made any changes to it.

Edit: It’s working with a VPN on. Maybe my network’s blocking the service being used, http://ix.io. Opening that link on my browser gives me warning anyway, saying that it doesn’t support HTTPS. Is it possible to change the service to something else? /etc/eos-sendlog.conf says EOS_SENDLOG_URI is no more used so I’m not sure what to do here.

It works for me and just reports it’s not secure because it’s not using https. But if your browser settings are set to https only then it would fail to open the site. Not sure about your VPN. Something you have to look at.

Is there a particular reason for using a site that doesn’t support HTTPS in 2023?

Also, this post mentions that more services are supported. How do I switch then, given the notice inside /etc/eos-sendlog.conf?

The only thing i can tell you is what i read here from the link. (wiki)

How was it implemented

The support was added by integrating the wgetpaste application into eos-sendlog. wgetpaste comes from an Arch package wgetpaste. Our integration uses a slightly modified package, wgetpaste-eos, which tries to use https instead of http if possible.
Note that you need to install wgetpaste-eos manually for it to work.

1 Like

Installing wgetpaste-eos seems to have fixed it. No need to modify configs. Now it works without a VPN and also returns HTTPS links.

I just installed it myself as i wasn’t using it. I’ll see what difference it makes for me. :thinking:

The problem is many pastebin like services are not really stable, they seem to have issues every now and then.
eos-sendlog is a wrapper for some pastebin services and it provides a very simple UI.

It is appreciated to report here on the forum if some pastebin service used by eos-sendlog is not working. Reporting helps in creating a reasonable workaround.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.