eOS no longer boots after CPU got temporarily removed

Today I replaced the heatsink in my computer with a new one, and unfortunately the cpu (ryzen 7 3700x) came off with it, thermal paste was rock solid.

After inspecting it, and concluding in the best of my visual capabilities it didn’t look damaged, I put it back in the socket and mounted the new heatsink, but after turning on the PC the CPU was identified as new CPU, I pressed the button to setup as instructed and it simply sent me to the bios. I didn’t think much of it but I am now unable to access my EndeavourOS.

After bios it goes to the grub as normal, where I have Endeavour and Windows.

The Windows partition works (writing this from there), although it messed up my login and I needed to reset the password.

Linux however, doesn’t boot at all. Black screen, monitors say no signal and it hangs there.

  • Tried running boot repair live usb, which was straightout ignored and proceeded to grub
  • Tried running boot repair from an ubuntu live usb, but it did nothing for me. It tried to reinstall the grub, asked me to insert some commands in the terminal and failed to proceed
  • Tried disabling secure boot via removal of PK key, but nothing changed

I don’t know what to do, I’m locked out of my system

Sad to hear…

Its possible to run endeavouros usb? Nothing changed internally on connectors or sit as it should be?

You can check blkid if the uuid stil match but endev iso should work if not… would it pretty weird

Did it actually work?
If Secure boot is on, then this might be the problem, as it sounds like it.

Turn off secure boot in the Bios. Even if you remove the keys and it’s still tuned on then it’s not likely going to boot EndeavourOS.

no, it didn’t help

as I said, I did turn it off but it didn’t help

Anyway, what happened later is that my installation SOMEHOW decided to let me boot in, but only one monitor would work, and it would give crazy artifacts and it was heavily unresponsive.
It came to my mind that I have a timeshift snapshot I made last month, so I tried restoring through all the glitchy mess, but even after that eOS was as unusable as before.

Out of frustration I decided to wipe my partition and reinstall, and then timeshift it, however I’m still having problems and can’t access it, because after restoring, grub gave me this dead end.

I thought it could’ve been a broken fstab, maybe the UUID was wrong, I went to check it, and it was, I tried replacing the UUID with the new one, but it still didn’t help. My knowledge ends there so now I’m stuck trying to get a functional grub working but I’m quite overwhelmed and I don’t understand how to do this

From what you said here… what i was getting at was if you only cleared the keys to try to disable secure boot. I was just saying make sure it was disabled in the Bios. Sounds like your frustrated. We are just trying to help.

Now you are in a clean state, a new installation. We need technical info, to see what is wrong.

This description is too poor to help us help you.
If you can boot to TTY, post your system info. Read this and give us something to work with.