EOS missing from grub - stick on grub-install: warning: File system `ext2' doesn't support embedding

This is a dual boot UEFI system after a reboot windows was the only option. Below is the output of what I have tried. Why am I getting grub-install: warning: File system `ext2' doesn't support embedding when attempting to reinstall grub via chroot?

[liveuser@eos-2023.03.26 ~]$ sudo lsblk -l
loop0       7:0    0   1.7G  1 loop /run/archiso/airootfs
sda         8:0    1  57.7G  0 disk 
sda1        8:1    1   1.8G  0 part /run/archiso/bootmnt
sda2        8:2    1   114M  0 part 
sdb         8:16   1     0B  0 disk 
nvme0n1   259:0    0 953.9G  0 disk 
nvme0n1p1 259:1    0   100M  0 part 
nvme0n1p2 259:2    0    16M  0 part 
nvme0n1p3 259:3    0 241.1G  0 part 
nvme0n1p4 259:4    0   530M  0 part 
nvme0n1p5 259:5    0  1000M  0 part 
nvme0n1p6 259:6    0 711.1G  0 part 
[liveuser@eos-2023.03.26 ~]$ sudo cryptsetup luksOpen /dev/nvme0n1p6 EOS
Enter passphrase for /dev/nvme0n1p6: 
[liveuser@eos-2023.03.26 ~]$ sudo mount /dev/m
mapper/ media0  mei0    mem     mqueue/ 
[liveuser@eos-2023.03.26 ~]$ sudo mount /dev/mapper/
control  EOS      
[liveuser@eos-2023.03.26 ~]$ sudo mount /dev/mapper/EOS /mnt
[liveuser@eos-2023.03.26 ~]$ sudo arch-chroot /mnt
[root@EndeavourOS /]# sudo efibootmgr
BootCurrent: 001C
Timeout: 2 seconds
BootOrder: 0006,0009,0001,0000,0010,0011,0012,0013,0017,0018,0019,001A,001B,001C,001D,001E,001F,0024,0004
Boot0000* OS on hard drive      HD(1,GPT,7b2afb50-ab50-4235-b58d-f08d26dab026,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)
Boot0001* Windows Boot Manager  HD(1,GPT,6ca14f15-4c5b-49f0-acef-dcce0ef697bf,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0004* Linux-Firmware-Updater        HD(1,GPT,7c2d3c30-309f-4c5b-aecd-3ab2bbd8f5ab,0x800,0x12c000)/File(\EFI\fedora\fwupdx64.efi)
Boot0006* endeavouros   HD(1,GPT,f6ebbc67-3a52-a649-957d-c6ca94da6a84,0x1000,0x1f4000)/File(\EFI\endeavouros\grubx64.efi)
Boot0009* Linux Boot Manager    HD(5,GPT,e82f537c-b170-f544-8de7-2d41850811d3,0x1e276d48,0x1f4000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0010  Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011  Boot Menu     FvFile(126a762d-5758-4fca-8531-201a7f57f850)
Boot0012  Diagnostic Splash Screen      FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0013  Lenovo Diagnostics    FvFile(3f7e615b-0d45-4f80-88dc-26b234958560)
Boot0014  Startup Interrupt Menu        FvFile(f46ee6f4-4785-43a3-923d-7f786c3c8479)
Boot0015  Rescue and Recovery   FvFile(665d3f60-ad3e-4cad-8e26-db46eee9f1b5)
Boot0016  MEBx Hot Key  FvFile(ac6fd56a-3d41-4efd-a1b9-870293811a28)
Boot0017* USB CD        VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0018* USB FDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0019* NVMe1 VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a401)
Boot001A* NVMe0 VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a400)
Boot001B* ATA HDD0      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot001C* USB HDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot001D* PCI LAN       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot001E  Other CD      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a35406)
Boot001F  Other HDD     VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f606)
Boot0020* USBR BOOT CDROM       PciRoot(0x0)/Pci(0x14,0x0)/USB(11,1)
Boot0021* USBR BOOT Floppy      PciRoot(0x0)/Pci(0x14,0x0)/USB(11,0)
Boot0022* ATA HDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f6)
Boot0023* ATAPI CD      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)
Boot0024* PCI LAN       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
[root@EndeavourOS /]# grub-install
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.
[root@EndeavourOS i386-pc]# grub-install --target=i386-pc /dev/mapper/EOS
Installing for i386-pc platform.
grub-install: warning: File system `ext2' doesn't support embedding.
grub-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.
[root@EndeavourOS i386-pc]# ls -la /boot
total 6916
drwxr-xr-x  3 root root    4096 May  2 19:57 .
drwxr-xr-x 19 root root    4096 May  2 20:03 ..
drwxr-xr-x  6 root root    4096 May  2 20:00 grub
-rw-r--r--  1 root root 7066624 Feb 14 19:22 intel-ucode.img

Because you try to install to MBR, instead of UEFI.
For UEFI, use this type:

grub-install --target=x86_64-efi --efi-directory=$esp --bootloader-id=FolderName

Also, you have not mounted ESP when using arch-chroot, which is probably nvme0n1p5.

Your /boot/ folder seems to not include any kernels, which should say something :wink: .

Proceed carefully. :face_with_monocle:

What can cause that to happen?

Are you sure you were using grub and not systemd-boot? Also, you need to mount your efi partition in your chroot.

Well that is problem number one, I just assumed it was grub

Check your /etc/fstab/ to see what your $ESP is.

From the LUKS chroot

cat /etc/fstab 
# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>

Are you sure that is from the chroot and not the ISO?

Your /etc/fstab should definitely not be empty.

opps here is the actual

cat fstab 
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=BD17-8E1F                            /efi           vfat    defaults,noatime 0 2
/dev/mapper/luks-26dd2156-e7e0-4d4e-8564-6358941669e0 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

This is your /efi. You can mount it like that. After mounting the luks volume, sudo mount UUID=BD17-8E1F /mnt/efi

Then sudo arch-chroot /mnt

From within the chroot, bootctl install

It mounts as read only regardless of if I run sudo mount… or switch to root and try the same command

You mean the EFI partition? That usually means either you didn’t disable “Fast Startup” in Windows or your ESP has filesystem errors that need to be repaired.

Disabling fast book in windows did allow me to mount the EFI partition with write permissions.

Attached is the output but I still do not have an EOS option at boot only windows 10
strong text

Go back into the chroot(with the efi partition mounted) and run reinstall-kernels

I can now boot EOS thanks for you help

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.