EOS Liveuser sudo password?

It’s super late/early, I just woke up, so maybe that’s the reason why I can’t find the password for the live user sudo password. Or maybe I’m just stupid.

My system froze today while running updates and my dracut boot entries were gone when I restarted, only allows boot into UEFI. I’m trying to fix this by chrooting with my EOS install USB. However, I don’t know/remember the live user sudo password.

Am I doing something wrong here?

All help would be appreciated.

I think it’s live.

Or endeavour.

type in:
sudo su


If I recall correctly, there is no live user password. A password should not be needed to use sudo to run a command.

Maybe I was too hasty… I rebooted the USB again and now I can do sudo without any password prompts. Thanks for the suggestions though!

I think I can do the recovery from here.

sudo lsblk -f:

[liveuser@eos-2023.02.08 ~]$ sudo lsblk -f
NAME        FSTYPE   FSVER            LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0       squashfs 4.0                                                                     0   100% /run/archiso/airootfs
└─sda1      ext4     1.0              BackupSSD   313a48ef-1001-43f9-a5cd-00040be3f1e1                
└─sdb1      ext4     1.0              Smol        b4cee6f6-c467-4b38-a61a-239c8c7062d6                
sdc         ext4     1.0              DataSSD     024f5ab9-cc2a-4329-8c43-42a0f174bca3                
sdd         iso9660  Joliet Extension EOS_202302  2023-02-08-15-44-26-00                              
├─sdd1      iso9660  Joliet Extension EOS_202302  2023-02-08-15-44-26-00                     0   100% /run/archiso/bootmnt
└─sdd2      vfat     FAT16            ARCHISO_EFI 41B6-5B8A                                           
├─nvme0n1p1 vfat     FAT32                        4791-A3F9                                           
├─nvme0n1p2 btrfs                                 a1b3e215-a6e9-4056-bf81-2f15dd9ac8ae                
└─nvme0n1p3 btrfs                                 0a6f03e2-577e-4a5b-b62c-45f42d318a7b

I should mount my EFI (nvme0n1p1), then mount my system partition (nvme0n1p2), then mount my Home partition (nvme0n1p3). Or maybe the Home partition isn’t needed for system update?

When these are mounted, arch-chroot, try to update the system again with “sudo pacman -Syu”, see if there are errors, if not, all should be good to go. Correct?

Correct. No idea why it prompted me for a password before, but rebooting into the USB seemed to help.

1 Like

Correct, but I think there’s something you need to do specific to a btrfs partition; I don’t use btrfs, but I do seem to recall that there’s something different that must be done. I might be wrong on that, though.

Unfortunately it’s getting late, and I’m too sleepy to look it up and check for you. Sorry.

No worries, sleep, as I should too. :smiley:

I do need to mount the subvolume schemes, but that’s easy. Only thing confusing me a bit is the fact that I have a separate home partition.

Figured it out!

sudo mount  /dev/nvme0n1p2  /mnt -o subvol=@
sudo mount  /dev/nvme0n1p1  /mnt/efi
sudo mount /dev/nvme0n1p3 /mnt/home
sudo arch-chroot /mnt

Then I had to remove pacman db.lock, after which I could fully update the system. Then, just to make sure I ran reinstall-kernels so dracut would rebuild everything. Then my system was able to boot into my system again.

Thanks for help everybody. I’ll mark this as solved.

That’s not the way i was doing arch-chroot on btrfs but good to know it works. I’m using grub also. Home is not on a separate partition either.

sudo mount -o subvol=@ /dev/nvmeon1p2 /mnt
sudo mount /dev/nvme0n1p1 /mnt/boot/efi
sudo mount -o subvol=@home /dev/nvme0n1p2 /mnt/home
sudo arch-chroot /mnt

I suppose there’s multiple ways of achieving the same goal? I’m not using grub. I used to have grub, but during recent reinstall I chose systemd + dracut as the way to go. I was a bit confusing to set up kernel parameters and stuff like that at first. :smiley:

Yes… lots of stuff is confusing for me also. :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.