Eos-kernel-nvidia-update-check keeps popping up

Quite often while I’m using my computer, this popup will suddenly show up:


First of all, it’s not quite clear what it asks if I want to continue with that it recommends against. I’m guessing an upgrade, but I wasn’t performing one to begin with. This time I was just watching a video on youtube when it suddenly showed up. Presumably due to checking for updates:

$ journalctl | grep eos | tail -n 1
Oct 03 00:00:16 pc eos-update-notifier[682925]: Checking for updates ...

Secondly (and probably most importantly), the nvidia package is not even installed, so it makes sense that it won’t be upgraded:

$ pacman -Qi nvidia
error: package 'nvidia' was not found

Worth noting is I do have an nvidia card in my computer, but it’s only used for PCI-e passthrough to a VM, and not used in Linux at all:

$ lspci -nn | grep -i nvidia
0d:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU102 [GeForce RTX 2080 Ti Rev. A] [10de:1e07] (rev a1)
0d:00.1 Audio device [0403]: NVIDIA Corporation TU102 High Definition Audio Controller [10de:10f7] (rev a1)
0d:00.2 USB controller [0c03]: NVIDIA Corporation TU102 USB 3.1 Host Controller [10de:1ad6] (rev a1)
0d:00.3 Serial bus controller [0c80]: NVIDIA Corporation TU102 USB Type-C UCSI Controller [10de:1ad7] (rev a1)
$ cat /etc/modprobe.d/vfio.conf 
options vfio-pci ids=10de:1e07,10de:10f7,10de:1ad6,10de:1ad7

the command would be pacman -Qs nvidia what would also sow package snot exactly named nvidia like nvidia-dkms p.e.

But could be also an issue with the tool?

Thanks for the report. :+1:

I think this can be solved by a rather easy change in the app.

For the record, what is the output of

lsmod | grep nvidia
pacman -Qsq nvidia


Fixed it (hopefully) in eos-bash-shared version 1.30-1.
Should be available in mirrors near you soon.

1 Like

Ah, fair. I chose -Qi specifically to exclude other packages, but you might be right that it’s picking up on something else. Output pasted below (in response to the other quote).

$ lsmod | grep nvidia
i2c_nvidia_gpu         16384  0
$ pacman -Qsq nvidia

Perfect, thanks for the quick fix! I’ll keep an eye out for the version next time I upgrade and will report back if it happens again. :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.