EOS is delayed

On this last month, I noticed a loss of performance in the opening of some applications as firefox and some others like Disks. Else, some softwares does not open and return an error (while I open them from plasma widgets, not from the start menu… maybe it’s a KDE Plasma issue?). Then, sometimes Dolphin does not shows any menu by right-click on the latte dock icon and lightdm dos not work properly (no background shown even changing settings both from lightdm greeter than manually changing the config file)
I supposed that some updates are in conflict (even mutter43 that conflicts with mutter… so budgie e gnome can’t stay both on the same system as before).
Anyone experienced the same?

Just delete xdg-desktop-portal-gnome. There have been numerous discussions about this, if you care to search this forum for the term:wink:

1 Like

i read…
If this is one of these what the hek i do simply install all DEs insall it will be impossible to find out what is causing issues … to many dependencies and interfering configurations could be in the way.

If so:
save your personal files and reinstall ONE (1) Desktop you want to use .
And if you want to try otehrs use a VM or install another instanc eof the OS.

1 Like

+100 for this. It you mix/max those huge DE:s you are just begging for trouble :smiley:


@joekamprad @bitterhalt

I installed almost all kind of DE and they don’t cause any particular problem. Before some updates, both Budgie and Gnome works as expected. Then, mutter caused a incompatibility and I had to choose the one I would keep. So, I uninstalled Budgie. The only thing that can happen having more DE installed is that, for some of them, if I change an icon theme or I change some settings, those are changed also for those DEs that share some graphic libraries and/or settings, but they don’t give any other problem. I “play” a lot with things like this and as a total newbie about the linux world, I can easily say that I don’t have to get crazy to solve any particular issue. EndeavourOS is very stable. Some bugs are normal and I don’t expect that anything works everytime for the muddle I do ;P!
Anyway, the point of this thread is not about DE but it’s about some loss of speed performance in the opening of some apps (some of them take very long time) and some issue encountered with lightdm. I guess they are given by some update.
So, no one experience the same?

indeed … your system your rules :wink: but also if you had no major issues before it can start be this with every update in case … no one has tested to run all DEs at once on the same OS instance anywhere and no package update will take vcare that this is fully working… packages do only solve package files and dependency.

You can check journal for any errors and warnings you can send it to me in P.M. if you want i would never post full journal public.
journalctl -b -0 will be full boot log…
you can create a file and send me that in P.M.
journalctl -b -0 >> flusso-journal.txt

Maybe I found something… reading what is returned from the command you suggested, I found a failed loading of the of an implementation of Gnome. I also found a thread on the arch forum for this:
https://bbs.archlinux.org/viewtopic.php?id=285590 for those had encoutered the same problem.
Now I haven’t so much time to check better the journal, anyway I will do for sure in the next days.
Thanks a lot!

seth: Even if you want need flatpak, you don’t require a specific portal implementation and as portal-gnome seems somewhat spellbound to mutter, just remove the package and use portal-gtk?

Seems legit…

you still not tried this?

Finally, I unistalled xdg-portal-gnome and installed xdg-portal-gtk instead.
Actually now it seems the issue is solved. Also, OBS Studio had an issue (black screen, no possibilites to capture); now this is solved too.

Please choose one of the posts in this topic to Mark as a Solution :white_check_mark:

1 Like

That is great to hear, but which post did show you in the right direction? - That post should really be named as “solution”.
Thank you…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.