EOS installation on RAID0 with blivet-gui

Hello everyone :wink:
I am standing of front problem to install EOS on RAID0 2 x Samsung 970Pro 512GB.
My machine is Alienware Area51m, i9-9900K, RTX2080, 64GB RAM HyperX, 2 x Samsung 970Pro 512GB, 1 x Samsung 870 EVO 1TB.
Last year I decided use this machine as daily driver with the Linux and run on it only Manjaro and EOS without without serious problems compared to other distributions.
Recently when come Cassini I decided use comp fully only for EOS without dual boot W11.
So I used one 970Pro W11 and second one for EOS.
In this moment I am trying to install EOS on RAID0 with 2 x Samsung 970Pro 512GB.
I know that Calamari not yet support RAID instalation.
I made some research on Arch wiki and Ubuntu wiki, Fedora wiki etc., I find out that perfect tool to prepare drives is “blivet-gui” which is recommended by Arch wiki for this reason.
However Arch wiki not provide more detail how to use it, so method trial and error lead me to result that I can install with Calamari EOS on RAID0 with 2 x Samsung 970Pro 512GB, clean fast installation no problem, however after first restart, system stop loading with:
A start job is running for /dev/disk/by-uuid/ …number… (1min 33s / no limit)
So i let it run 45 min. and then CTRL+ALD+DEL restart to EOS on 1TB SSD which I used for prepare SSDs (research + trials and errors) with blivet-gui.
In blivet-gui configuration of NVME are:
nvme0n1p1 = 1024 MiB EFI partition Fat32
RAID0 = 451.63 GiB all that’s left, ext4
RAID0 = 451.63 GiB all that’s left, ext4
Free space 1024 MiB
RAID0 MDArray ext4 951.63 GiB
After set SSDs with blivet-gui, normal start Installation until step when is necessary choose where to install and how set SSD.
Because is all already set then just edit RAID0 Array if is all OK and continue to finish installation which is always ended without any ERROR.
First restart but not load system with loading status as I stated above.
So I tried again trial and error method but no success.
I see big potential and simplicity in blivet-gui as graphical application for this reason made however lack of detailed documentation and how to prepare drives for many possible variants inhalations btrfs RAID, LVM, LVM on RAID, ext4, and many options encryption for all problem which I read here with LVM, RAID and encryption.
So my question is if somebody has more experience with blivet-gui to set RAID0 with 2 x Samsung 970Pro 512GB for installation EOS please let me know I will also share all what I find out on my route trial and error with this super app.
Many thanks

Have you tried booting the fallback image from the boot menu after installing?

Thanks so much for very quick reaction, I am happy that team EOS is so dynamic :+1:
I really do not know sure, because I made more then 50 installation last 3 days, however if will be result positive and system start probably I will continue in research to find out what is root cause and try it fix it.
I am really newbie with Archlinux and based distros (about 3 years) and still I need more learn, sorry.
Hovewer Ill made another installation with the same parameters and let you know on 05/03.

The issue is that the installer probably doesn’t have support for md arrays. If you are using the blivet-gui to create the array before hand, it will probably install.

I would think there are two possible issues that are most likely if the installer is completing successfully.

  • The boot image doesn’t include md support
  • The kernel command line is not correct

The fallback image usually includes support for more features so that is what I would check first. If that doesn’t work, we will need to look at your kernel options.

Thanks, this is make sense, I am working now on new installation.
Array is created before start instillation on separate SSD with EOS and after installation has laptop dual boot with two EOS one on Samsung 870 evo 1TB which I use for blivet-gui, and second is EOS on RAID0 which is not loading.
Maybe this can be also problem dual EOS on one machine.

Now I am going install EOS on RAID0 with 2 x Samsung 970Pro 512GB and I will try booting the fallback image.
See you later cca 20 min.

1 Like

I don’t think you even need to use blivet-gui but that’s okay if it’s easier. You could just use gparted and fdisk to do the same thing and use mdadm to set up the array. Then run the installer using manual partition to set the boot drive and file system and root.

Here is an example on PopOS shouldn’t be much different on EndeavourOS.

Hi, thanks
booting the fallback image is the same result
Actually what I want to achieve is have 1TB as one drive does nott matter if is LVM or RAID0, hovewer I thing that RAID0 with fast nvme could be more faster then one nvme.
It will be interesting to try it and share experience. Samsung 970Pro is not bad RAM.
Definitely I will tray research information from Installing PopOS on RAID0, but PopOS based on Ubuntu and Debian is not very nice solution and I prefer KDE Plasma.
Solution will be Kubuntu I run it about two years on ASUS laptop until I bought Area51m.
I also made installation log from last installation so is it also material for review and study.
I let you know and many thanks for educational information.

Did you choose systemd-boot or grub?

I’m just saying the setup and installation shouldn’t be much different. Normally RAID0 is two drives of the exact same size and type normally. RAID0 is just mirroring one drive to the other.

It could be a little different.

No, that is raid 1. Raid 0 is striping the two drives.

Yes, sorry you are right. Darn terminology!

Yes I need strip of 2 drives, Samsung 970Pro is very stable and comp will be used as daily driver and gaming not for some science or AI with big data.

so I tray PopOS version bud PopOS in my configuration with nVIDIA start USB to black screen known problem many years with nVIDIA, even I made PopOS install version with support nVIDIA from their web page.
Then I tried last version Manjaro, instalation OK no error after restart to new OS long time loading and then pop up message:

mount: /new_root: can’t find UUID-5b679dde-…-…-…
You are now being dropped into an emergency shell.
sh: can’t access tty: job control turned off

I am aware and have experience with UUID from Archlinux installation, so is clear that somewhere of process of installation is necessary setup UUID for EOS or Manjaro.
It is look like that I will have to again renew installation knowledge with Archlinux where is possible in installation process setup RAID0.
I choose Archlinux distros Manjaro and EOS because it was only linux platform which is possible to install on Alienware Area51m and all is work as like in Windows 10 or 11 and is fastest about 10-15% in gaming depend on game, DayZ, all Fallouts, Portal, Portal RTX, Portal 2, all Metros Exodus, Cyberpunk etc., include Ray Tracing all work perfectly with FPS slightly highest about 2-5% then in Windows.
I just need made two Samsung 970Pro 512GB as like one volume doesn’t matter if is RAID0 or LVM.
In this moment after all tinkering with RAID0, I going to try LVM but I have no clue how to.
if somebody have knowledge how to setup LVM on two nvme or know where can find some info pls let me know.
Have nice weekend :wink:

If you switch to Btrfs, it has an incredibly simple setup for RAID0. You don’t need blivet-gui or any other application, just go through the installer like normal (as if your extra disk is not even there), and then set up the RAID afterward with mkfs.btrfs. With mkfs.btrfs, you can simultaneously format the extra drive as Btrfs and also identify it as a RAID device. See here: Using Btrfs with Multiple Devices - btrfs Wiki

# Stripe the data without mirroring, metadata are mirrored
mkfs.btrfs -d raid0 /dev/sdb /dev/sdc

There is basically nothing else to it, you don’t even need to change fstab or anything because you can mount a Btrfs RAID using any disk used in creating the RAID.

Here is a little walk-through style article, although for RAID0 it is basically just the one command:

Thanks for tip, and I tried it, and is works as secondary disk, but install EOS on btrfs RAID0 always end “A start job is running for /dev/disk/by-uuid/ …” without start EOS

When you install EOS on Btrfs, you get the “start job” error?

Just to clarify: setting up the RAID would not be part of the installation when making a RAID0 configuration with Btrfs as described above, you would do it afterward. For the installation, I would just pretend the extra disk isn’t even there.

here is my output to use mkfs.btrfs -d raid0 /dev/nvme0n1 /dev/nvme1n1

I cane try to start EOS instalation and again use metod test and error with Calamary to install on this RAID0 array.
Befor I made RAID0 array with help blivet-gui and first restart always end with A start job is running for /dev/disk/by-uuid/… once I waited 45 min. I just take break and let it run.
However if I will give up then I will install EOS on nvme0n1 and nvm1n1 mount as data disk where I will probably move Steam library.
But go back to W11 no way, I tested speed and stability EOS vs W11 particularly with AI apps and games and EOS is definitely big winner with this hardware configuration.

Install EndeavourOS on one drive. Then after the installation run mkfs.btrfs -d raid0 /dev/nvme0n1 /dev/nvme1n1

I think this is what @BluishHumility means. :thinking:

1 Like

Yes, that looks good.

The RAID0 would be set up after the installation. So:

  1. Install EOS on a single disk, no RAID setup so far
  2. Boot to the fresh installation
  3. Add the RAID0 setup as you have above.

That’s it. :slightly_smiling_face:

Yes, exactly. Take the RAID setup out of the installation process altogether. No blivet-gui or anything else, just a normal installation on the one single disk.