EOS -- ideal LFS host

Just over a week ago I started on a Linux From Scratch 9.0 system v install, scouting around for a host system that would “just work” without any faffing around. From Ubuntu 18.04, through whatever the latest Fedora is, Gentoo’s latest LiveCD (2015!) and Tumbleweed none worked with tweaking and additional package installs.

Can you guess which ISO just worked? EndeavourOS**. I was a pretty happy KDE Neon user, and was not really looking to jump ship, but, I have to say it, Endeavour feels just right.

** I have an issue with video playback in browsers, but’s pretty inconsequential for me right now.

So, many thanks to the devs and the community around them. You’ve found yourself an advocate!


You may need to install pepper-flash.

hello, you have like pc and in which browser did you have the problem

I sincerely doubt that… videos do not play in Google Chrome either. I’ll get just a few frames (literally) then it will go back to something that looks like buffering.

Right now Virtual Box 6 in KDE Neon on a Lenovo t460.

I have no flash player, however youtube works very well

1 Like

youtube do not need flash anymore…
and video playback inside a browser inside a vm… it is working here with 3d enabled for the vm (virtualbox) and 256 MB setup for the video using VboxSVGA

with LFS host you mean running a VM to play with LFS?

1 Like

I don’t doubt that it is! That is why this is so frustrating. EOS (KDE or XFCE) + either Konqueror, Firefox or Google-Chrome == no video playback in VirtualBox 6.0.15 on MacOS Catalina. It cannot be my VBox settings since I use the base for every VM I create (it is scripted), and I’ve never had this problem before.

Yes. the Endeavour OS VM has a second .vdi attached to it, mounted to an area where I can compile the source packages, once all the chrooting shenanigans are done and the system can stand on its own, I’ll detatch/unmount it. This is irrelevant to the videoplayback issue, though.

This sounds like something related to the host system then. May need some different settings, as I do host vm on Linux here.
I would research on this over macos + virtualbox issues with video playback


Say 3d is experimental…
And you have guest additions installed?

Aaand we’re golden with VirtualBox 6.1.2!

That was a weird ride indeed.

Thanks or your help.