EOS grub-install error 1

Hello all

I beg your help about a fresh eos installation on an old laptop Asus X552M. The installation stopped at grub step exited with error 1. I read all topics it was possible to help me in my case, I tried all tips which were advised but none worked for me :confused:
As I understood, I can consider than eos is installed, I just need to correct the issue with grub, am I right?
Below the commands and their returns I got:

[liveuser@eos-2022.06.23 ~]$ sudo efibootmgr -V
version 17

Which mean this 17?

[liveuser@eos-2022.06.23 ~]$ sudo bootctl status
Couldn’t find EFI system partition. It is recommended to mount it to /boot or /efi.
Alternatively, use --esp-path= to specify path to mount point.
Firmware: UEFI 2.31 (American Megatrends 5.09)
Secure Boot: disabled (disabled)
TPM2 Support: no
Boot into FW: supported
Current Boot Loader:
Product: systemd-boot 251.2-1-arch
Features: ✓ Boot counting
✓ Menu timeout control
✓ One-shot menu timeout control
✓ Default entry control
✓ One-shot entry control
✓ Support for XBOOTLDR partition
✓ Support for passing random seed to OS
✓ Load drop-in drivers
✗ Boot loader sets ESP information
ESP: n/a
Random Seed:
Passed to OS: no
System Token: not set

[liveuser@eos-2022.06.23 ~]$ sudo rm /sys/firmware/efi/efivars/dump-*
rm: cannot remove ‘/sys/firmware/efi/efivars/dump-*’: Invalid argument

In this folder, there are only 74 files for 18.8 KiB

[liveuser@eos-2022.06.23 ~]$ sudo fdisk -l
Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: TOSHIBA MQ01ABD1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 625E5BDB-589B-F049-9506-4E37C7728D05
Device Start End Sectors Size Type
/dev/sda1 4096 618495 614400 300M EFI System
/dev/sda2 618496 1935065126 1934446631 922.4G Linux filesystem
/dev/sda3 1935065127 1953520064 18454938 8.8G Linux swap

I also tried to remove, in livecd mode, the boot partition and recreated another one but the installer didn’t give me the flags boot,esp options and the next button was greyed :woozy_face:

Thank’s for reading, any helps are welcome

is fastboot desactived ?
is No CSM ?
all disks are on AHCI ?
is Legacy desactived ?

Did you try installing systemd-boot, by chance? Curious why your OP is showing this:

Product: systemd-boot 251.2-1-arch
-v | --verbose          print additional information
-V | --version          return version and exit

To see the information on your efi boot entries you would need to pass -v.
-V shows the version of efibootmgr.

:eye: efibootmgr --help


Hello I did nothing with system-boot. I can’t explain that

The only HDD installed is in AHCI mode
CSM is disabled
Fastboot disabled too
No bios with legacy option

[liveuser@eos-2022.06.23 ~]$ efibootmgr -V | --version
bash: --version: command not found
[liveuser@eos-2022.06.23 ~]$ efibootmgr -v | --verbose
bash: --verbose: command not found

Idem with sudo :woozy_face:

Try the following:

  1. Boot up your live USB

  2. Launch Gparted and make a new partition table on your drive. This will wipe out your whole drive.
    In Gparted >> menubar >> Device >> new partition table >> GPT
    When done, close Gparted.

  3. Launch the installer. Choose automatic install. (Erase and install or some such)

  4. In case it fails again, run the log tool and get the URL for the installation log. Post the URL on the forum.


efibootmgr -v 
efibootmgr -V
1 Like

It failed :confused:
Grub-install error 1 - Asus X552M

[liveuser@eos-2022.06.23 ~]$ efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001
Boot0001* UEFI: ASolid USB 0000 PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/HD(1,MBR,0xab3ab792,0x369fc0,0x33000)…BO
[liveuser@eos-2022.06.23 ~]$

[liveuser@eos-2022.06.23 ~]$ efibootmgr -V
version 17
[liveuser@eos-2022.06.23 ~]$

Never mind - I didn’t notice that you were posting from the live ISO environment.

One more question: have you updated the BIOS on this laptop recently?

Copying and executing commands, without knowing what they do, will eventually lead you to a system and/or hardware damage. Be cautious and read documentation. I say this because you have made several mistakes. :person_shrugging:

From the installer ISO, start a terminal and confirm your target (installation) drive is /dev/sda.
Then mount the two partitions (root and esp) and try to install grub again. If there is an error message, post all terminal content here, so we can advise you further.

sudo mount /dev/sda2 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/mnt/boot/efi --boot-directory=/mnt/boot --bootloader-id=Grub --force
sudo grub-install --target=x86_64-efi --efi-directory=/mnt/boot/efi --boot-directory=/mnt/boot --bootloader-id=SystemGrub --force --removable

If the above installation commands succeed, check for new boot entries:

efibootmgr -v

and with success, run also this:

sudo grub-mkconfig -o /mnt/boot/grub/grub.cfg

If no errors, reboot to check it works.
If it boots fine, run again from the installed system in terminal

sudo grub-mkconfig -o /boot/grub/grub.cfg

Good luck, with some reading for help :wink:


Hello petsam,
Thank’s a lot for your help, I agree about the mistakes I could have done, this kind of troubleshooting is too hard for me, all documentations I will able to read, I will have so many questions behind :confused:

I did your troubleshooting, I accessed to the boot menu, now only these 2 lines are displayed, nothing more, finished by an hard reboot

Loading Linux linux-lts …
Loading initial ramdisk …

As requested, the logs you asked me to do:

[liveuser@eos-2022.06.23 ~]$ sudo mount /dev/sda2 /mnt
[liveuser@eos-2022.06.23 ~]$ sudo mount /dev/sda1 /mnt/boot/efi
[liveuser@eos-2022.06.23 ~]$ sudo grub-install --target=x86_64-efi --efi-directory=/mnt/boot/efi --boot-directory=/mnt/boot --bootloader-id=Grub --force
Installing for x86_64-efi platform.
Could not prepare Boot variable: Input/output error
grub-install: error: efibootmgr failed to register the boot entry: Input/output error.
[liveuser@eos-2022.06.23 ~]$ sudo grub-install --target=x86_64-efi --efi-directory=/mnt/boot/efi --boot-directory=/mnt/boot --bootloader-id=SystemGrub --force --removable
Installing for x86_64-efi platform.
Installation finished. No error reported.

[liveuser@eos-2022.06.23 ~]$ efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001
Boot0001* UEFI: ASolid USB 0000 PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/HD(1,MBR,0xab3ab792,0x369fc0,0x33000)…BO

The boot failed but I did them by curiosity, both got the same error message

[liveuser@eos-2022.06.23 ~]$ sudo grub-mkconfig -o /mnt/boot/grub/grub.cfg
/usr/bin/grub-probe: error: failed to get canonical path of `airootfs’.

[liveuser@eos-2022.06.23 ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
/usr/bin/grub-probe: error: failed to get canonical path of `airootfs’.

These failed errors make me crazy :tired_face:

ISO is using systemd-boot on uefi systems to boot…

If you want to maintain your sanity, you need to start reading and learning about Linux systems, since you are attempting to be a Linux system administrator.
Or did you think that it’s just a game, like those you like to play in WinOS? :joy: No, no, no!

The second grub installation command seems it has succeeded. You are probably ready.
You should be able to boot to EnOS, using the UEFI Quick Boot menu (shortcut key can be found in User Manual), and try all entries. If there is one that displays the drive (like HDD TOSHIBA… or similar), try it first.

You tried this on the USB installer system, which is not possible, and… does not make much sense :wink:

Anyway, it looks like you have one of the bad UEFI firmware and you may need more work than is usually required.
I suggest you have patience, or just try Ubuntu, Mint, Fedora or WinOS.

you have some confusion about the Live Session and the installed system.
You can not run a command on the live session to change the installed system without following the right mount and path … /boot/grub/grub.cfg is a path on the “ISO”

To change installed system you need to mount the needed partitions to a mount point like /mnt and you can change stuff using the path under /mnt on installed systemfiles…

If you need to run commands onto installed system you will need to use chroot or better arch-chroot to get into the installed system and be able to run commands like you where booted into the same…



to see what exactly went wrong it would need the failed install log you can provide from installed system path or directly after it fails from the live session home folder path…

cat /var/log/endeavour-install.log | eos-sendlog 

or where ever you mount the installed system if you are booted into livesession (iso)
cat /mnt/var/log/endeavour-install.log | eos-sendlog

or reach it from filebrowser and copy the path…

1 Like